poj1408 Fishnet

Fishnet
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2103 Accepted: 1325

Description

A fisherman named Etadokah awoke in a very small island. He could see calm, beautiful and blue sea around the island. The previous night he had encountered a terrible storm and had reached this uninhabited island. Some wrecks of his ship were spread around him. He found a square wood-frame and a long thread among the wrecks. He had to survive in this island until someone came and saved him.

In order to catch fish, he began to make a kind of fishnet by cutting the long thread into short threads and fixing them at pegs on the square wood-frame. He wanted to know the sizes of the meshes of the fishnet to see whether he could catch small fish as well as large ones.

The wood frame is perfectly square with four thin edges on meter long: a bottom edge, a top edge, a left edge, and a right edge. There are n pegs on each edge, and thus there are 4n pegs in total. The positions of pegs are represented by their (x,y)-coordinates. Those of an example case with n=2 are depicted in figures below. The position of the ith peg on the bottom edge is represented by (ai,0). That on the top edge, on the left edge and on the right edge are represented by (bi,1), (0,ci) and (1,di), respectively. The long thread is cut into 2n threads with appropriate lengths. The threads are strained between (ai,0) and (bi,1),and between (0,ci) and (1,di) (i=1,...,n).

You should write a program that reports the size of the largest mesh among the (n+1)2 meshes of the fishnet made by fixing the threads at the pegs. You may assume that the thread he found is long enough to make the fishnet and the wood-frame is thin enough for neglecting its thickness.

Input

The input consists of multiple sub-problems followed by a line containing a zero that indicates the end of input. Each sub-problem is given in the following format.
n
a1 a2 ... an
b1 b2 ... bn
c1 c2 ... cn
d1 d2 ... dn
you may assume 0 < n <= 30, 0 < ai,bi,ci,di < 1

Output

For each sub-problem, the size of the largest mesh should be printed followed by a new line. Each value should be represented by 6 digits after the decimal point, and it may not have an error greater than 0.000001.

Sample Input

2
0.2000000 0.6000000
0.3000000 0.8000000
0.1000000 0.5000000
0.5000000 0.6000000
2
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
0.3333330 0.6666670
4
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
0.2000000 0.4000000 0.6000000 0.8000000
0.1000000 0.5000000 0.6000000 0.9000000
2
0.5138701 0.9476283
0.1717362 0.1757412
0.3086521 0.7022313
0.2264312 0.5345343
1
0.4000000
0.6000000
0.3000000
0.5000000
0

Sample Output

0.215657
0.111112
0.078923
0.279223
0.348958

题意:看图像应该不难看懂,告诉你一个长度为1的方格,然后分别告诉你边缘上的n个点。现在把对边相对应的点相连,将正方形分割成(n+1)*(n+1)个小四边形。问最大的四边形的面积是多少。

思路:先把这些对应的点相连,然后求出交点来,外围的交点相当于已经告诉你了。

然后问题就变成给你4个点怎么求面积了,我们已经学习过叉积了(可以参照上篇博客),所以可以根据叉积来求(把四边形分解成两个三角形)。(注意叉积可能是负的,我们只取正)

这道题只要敢做,有了前两道题的经验,做起来还不是很难的。

#include <iostream>
#include <cmath>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int MAXN=30+10;
struct point
{
    double x,y;
}p[MAXN][MAXN];

double chaji(double x1,double y1,double x2,double y2)
{
    return x1*y2-x2*y1;
}
double cross(point A,point B,point C,point D)//计算AB×(叉乘)CD
{
    return chaji(B.x-A.x,B.y-A.y,D.x-C.x,D.y-C.y);
}

double xx,yy;
void get_jiaodian(point A,point B,point C,point D)//求AB和CD的交点,这里AB和CD一定是规范相交的
{
    double area1=cross(A,B,A,C);
    double area2=cross(A,B,A,D);
    xx=(area2*C.x-area1*D.x)/(area2-area1);
    yy=(area2*C.y-area1*D.y)/(area2-area1);
}
double get_area(point A,point B,point C,point D)//已知ABCD四点求其四边形面积
{
    double s1=fabs(0.5*cross(A,B,A,C));
    double s2=fabs(0.5*cross(A,B,A,D));
    return s1+s2;
}
int n;
void in()//先建立交点矩阵
{
        int i,j;
        p[0][0].x=p[0][0].y=0;
        p[n+1][0].x=0.0;p[n+1][0].y=1.0;
        p[0][n+1].x=1.0;p[0][n+1].y=0.0;
        p[n+1][n+1].x=1.0;p[n+1][n+1].y=1.0;
        for(i=1;i<=n;++i)
        {
            scanf("%lf",&p[0][i].x);
            p[0][i].y=0.0;
        }
        for(i=1;i<=n;++i)
        {
            scanf("%lf",&p[n+1][i].x);
            p[n+1][i].y=1.0;
        }
        for(i=1;i<=n;++i)
        {
            scanf("%lf",&p[i][0].y);
            p[i][0].x=0.0;
        }
        for(i=1;i<=n;++i)
        {
            scanf("%lf",&p[i][n+1].y);
            p[i][n+1].x=1.0;
        }
        //枚举每条横竖线段,求其交点
        for(i=1;i<=n;++i)
            for(j=1;j<=n;++j)
        {
            get_jiaodian(p[i][0],p[i][n+1],p[0][j],p[n+1][j]);
            p[i][j].x=xx;
            p[i][j].y=yy;
        }
}
int main()
{

    int i,j;
    while(~scanf("%d",&n)&&n)
    {
        in();
        double max_area=0.0;
        //计算面积找最大值
        for(i=1;i<=n+1;++i)
            for(j=1;j<=n+1;++j)
        {
            double temp=get_area(p[i][j],p[i-1][j-1],p[i][j-1],p[i-1][j]);
            max_area=max(max_area,temp);
        }
        printf("%.6f\n",max_area);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值