POJ 2081

Description
The Recaman’s sequence is defined by a0 = 0 ; for m > 0, a m = a m−1 − m if the rsulting a m is positive and not already in the sequence, otherwise a m = a m−1 + m.
The first few numbers in the Recaman’s Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 …
Given k, your task is to calculate a k.

Input
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.

Output
For each k given in the input, print one line containing a k to the output.

Sample Input

7
10000
-1

Sample Output

20
18658

题意:
题意大概就是就是第m个位置的数是根据第m-1位置的数推出来的如果a[m-1]-m>0,并且a[m-1]-m在前面的序列中没有出现过那么a[m] = a[m-1]-m否则a[m] = a[m-1]+m

思路:
公式都已经写好了,只需要加一个bool值来标记当前a[m]是否出现过就可以了

代码:

import java.util.Arrays;
import java.util.Scanner;

public class Test1 {
    private static int[] array = new int[500005];
    private static boolean[] flag = new boolean[10000000]; 
    public static void main(String[] args) {
    Arrays.fill(flag, false);
    Arrays.fill(array, 0);
    for (int i = 1; i <=500000 ; i++) {
        if (array[i-1]-i>0 && flag[array[i-1]-i]==false) {
        array[i] = array[i-1]-i;
        }else 
        array[i]= array[i-1]+i;
        flag[array[i]] = true;

    }
    Scanner scanner = new Scanner(System.in);
    while (scanner.hasNext()) {
        int n = scanner.nextInt();
        if (n<0) 
        break;
        System.out.println(array[n]);
    }
    scanner.close();
    }

}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值