POJ 2376 Cleaning Shifts(区间贪心)

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2
题目大意是有n头牛,每头牛都有一个工作区间,一共t个时间,问你怎么安排才能让牛的个数最少且必须保证每个时间都有牛工作。

贪心先按开始顺序排序,然后从第i头牛开始找,后面的要作为他的接班人,必须开始时间不能超过第i头牛的结束时间+1,故在这里面找,肯定是找结束时间最晚的划算,所以再找到结束时间最晚的就行了。最后还得注意能不能完成这个任务。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct node
{
    int st,en;
}no[25005];

bool cmp(node a,node b)
{
    if(a.st==b.st)
        return a.en>b.en;
    return a.st<b.st;
}

int main()
{
    int n,t;
    while(scanf("%d %d",&n,&t)!=EOF)
    {
        int minn=1000001,maxx=-1;
        for(int i=0;i<n;i++)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            no[i].st=a;no[i].en=b;
            minn=min(minn,a);
            maxx=max(maxx,b);
        }
        sort(no,no+n,cmp);
        int ans=1;int num=0;int be=1;
        while(be<n)
        {
            bool first=true;
            int num1=num;//num1是下一个可能的序号
            while(be<n&&no[be].st<=no[num].en+1)//寻找下一个.
            {
                first=false;
                if(no[be].en>no[num1].en)
                    num1=be;
                be++;
            }

            if(num!=num1)//说明找到了下一个
            ans++;
            num=num1;
            if(first){
                    ans=-1;break;
            }
        }
        if(minn!=1||maxx!=t)cout<<-1<<endl;
        else
            cout<<ans<<endl;
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值