HDU 1016(Prime Ring Problem)

                                              Prime Ring Problem
           Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                        Total Submission(s): 70037    Accepted Submission(s): 29967

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<iostream>
#include<cmath>
using namespace std;
int n;
bool fun2(int * a,int c,int b)
{
	int m=0,j;
	for(j=0;j<b;j++)
	{
		if(a[j]==c)
		{
			m=1;
			break;
		}
	}
	if(m==1)
	{
		return false;
	}
	else
	{
		return true;
	}
}
bool fun1(int c,int d)
{
	int m=0,i;
	for(i=2;i<=sqrt(c+d);i++)
	{
		if((c+d)%i==0)
		{
			m=1;
			break;
		}
	}
	if(m==1)
	{
		return false;
	}
	else
	{
		return true;
	}
}
int fun(int * a,int b)
{
	int i;
	if(b==n)
	{
		if(fun1(a[b-1],a[0]))
		{
			for(i=0;i<b;i++)
			{
				cout<<a[i];
				if(i!=(b-1))
					cout<<' ';
			}
			cout<<endl;
		}
		return 0;
	}
	else
	{
		for(i=2;i<=n;i++)
		{
			if(fun2(a,i,b))
			{
				if(fun1(a[b-1],i))
				{
					a[b]=i;
					fun(a,++b);
					b--;
				}
			}
		}
		return 0;
	}
}
int main()
{
	int a[21]={0},i,cnt=0,s=1;
	while(cin>>n)
	{
		cout<<"Case "<<s<<":"<<endl;
		cnt=0;
		a[cnt]=1;
		fun(a,++cnt);
		cnt--;
		cout<<endl;
		s++;
	}
}
### IntelliJ IDEA 中通义 AI 功能介绍 IntelliJ IDEA 提供了一系列强大的工具来增强开发体验,其中包括与通义 AI 相关的功能。这些功能可以帮助开发者更高效地编写代并提高生产力。 #### 安装通义插件 为了使用通义的相关特性,在 IntelliJ IDEA 中需要先安装对应的插件: 1. 打开 **Settings/Preferences** 对话框 (Ctrl+Alt+S 或 Cmd+, on macOS)。 2. 导航到 `Plugins` 页面[^1]。 3. 在 Marketplace 中搜索 "通义" 并点击安装按钮。 4. 完成安装后重启 IDE 使更改生效。 #### 配置通义服务 成功安装插件之后,还需要配置通义的服务连接信息以便正常使用其提供的各项能力: - 进入设置中的 `Tools | Qwen Coding Assistant` 菜单项[^2]。 - 填写 API Key 和其他必要的认证参数。 - 测试连接以确认配置无误。 #### 使用通义辅助编程 一旦完成上述准备工作,就可以利用通义来进行智能编支持了。具体操作如下所示: ##### 自动补全代片段 当输入部分语句时,IDE 将自动提示可能的后续逻辑,并允许一键插入完整的实现方案[^3]。 ```java // 输入 while 循环条件前半部分... while (!list.isEmpty()) { // 激活建议列表选择合适的循环体内容 } ``` ##### 解释现有代含义 选中某段复杂的表达式或函数调用,右键菜单里会有选项可以请求通义解析这段代的作用以及优化意见。 ##### 生产测试案例 对于已有的业务逻辑模块,借助于通义能够快速生成单元测试框架及初始断言集,减少手动构建的成本。 ```python def test_addition(): result = add(2, 3) assert result == 5, f"Expected 5 but got {result}" ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值