POJ 3176 Cow Bowling(基础DP)

这篇博客介绍了如何解决POJ 3176 Cow Bowling问题,这是一个涉及基础动态规划的算法挑战。文章通过定义dp状态转移方程`dp[i][j] = max(dp[i + 1][j], dp[i + 1][j + 1]) + a[i][j]`来求解路径上元素和的最大值,并提供了相应的代码实现。" 119266180,10554152,优化网络:MTU值设置与影响,"['网络配置', '服务器优化', '网络性能']

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Cow Bowling

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

经典的动态规划

定义dp[i][j]为从底端到第i行j列元素所经过的路径上元素和的最大值,所以

dp[i][j] = max(dp[i + 1][j],dp[i + 1][j + 1]) + a[i][j]

代码如下:

#include <cstdio>
#include <algorithm>

using namespace std;
const int maxn = 355;

int dp[maxn][maxn],a[maxn][maxn];
int main()
{
	int n,i,j,k;
	while(scanf("%d",&n) != EOF){
		for(i = 0;i < n;i++){
			for(j = 0;j <= i;j++){
				scanf("%d",&a[i][j]);
			}
		}
		for(i = n - 1;i >= 0;i--){
			for(j = 0;j <= i;j++){
				dp[i][j] = max(dp[i + 1][j],dp[i + 1][j + 1]) + a[i][j];
			}
		}
		printf("%d\n",dp[0][0]);
	}
	return 0;
 } 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值