Cow Bowling
Description
The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:
Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.
Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output
Line 1: The largest sum achievable using the traversal rules
Sample Input
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
经典的动态规划
定义dp[i][j]为从底端到第i行j列元素所经过的路径上元素和的最大值,所以
dp[i][j] = max(dp[i + 1][j],dp[i + 1][j + 1]) + a[i][j]
代码如下:
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 355;
int dp[maxn][maxn],a[maxn][maxn];
int main()
{
int n,i,j,k;
while(scanf("%d",&n) != EOF){
for(i = 0;i < n;i++){
for(j = 0;j <= i;j++){
scanf("%d",&a[i][j]);
}
}
for(i = n - 1;i >= 0;i--){
for(j = 0;j <= i;j++){
dp[i][j] = max(dp[i + 1][j],dp[i + 1][j + 1]) + a[i][j];
}
}
printf("%d\n",dp[0][0]);
}
return 0;
}