杭电 1102 Constructing Roads 【最小生成树&&Kruskal】

本文介绍了一个村庄间的道路构建问题,通过使用最小生成树算法确保所有村庄互相连接且总道路长度最短。输入包括村庄数量、村庄间距离及已建道路信息,输出为所需构建的最短道路总长度。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17411    Accepted Submission(s): 6617


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 


 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 


 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 


 

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 


 

Sample Output
  
  
179
 

友情提示:数组开大点。。。尽可能的大,要不过不了。。。

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int pre[10100], k;

struct node{
	int u, v, w;
};
node edge[1010000];

int cmp(node a, node b){
	return a.w < b.w;
}

void init(){
	int i;
	for(i = 0; i < 10100 ; ++i)
	pre[i] = i;
}

int find(int x){
	int r = x;
	while(pre[r] != r)
	r = pre[r];
	pre[x] = r;
	return r;
}

void kruskal(){
	int i, sum = 0, fx, fy;
	init();
	sort(edge, edge + k, cmp);
	for(i = 0; i < k; ++i){
		fx = find(edge[i].u);
		fy = find(edge[i].v);
		if(fx != fy){
			pre[fx] = fy;
			sum += edge[i].w;
		}
	}
	printf("%d\n", sum);
}

int main(){
	int n, m;
	while(~scanf("%d",&n)){
		int i, j, x;
		k = 0;
		for(i = 1; i <= n; ++i){
			for(j = 1; j <= n; ++j){
				scanf("%d",&x);
				if(j > i){
					edge[k].u = i;
					edge[k].v = j;
					edge[k].w = x;
					k++;
				}
			}
		}
		scanf("%d",&m);
		for(i = 0; i < m; ++i){
			scanf("%d%d", &edge[k].u, &edge[k].v);
			edge[k].w = 0;
			k++;
		}
		kruskal();
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值