1086 就不告诉你 (15分)
做作业的时候,邻座的小盆友问你:“五乘以七等于多少?”你应该不失礼貌地围笑着告诉他:“五十三。”本题就要求你,对任何一对给定的正整数,倒着输出它们的乘积。
输入格式:
输入在第一行给出两个不超过 1000 的正整数 A 和 B,其间以空格分隔。
输出格式:
在一行中倒着输出 A 和 B 的乘积。
输入样例:
5 7
输出样例:
53
#include<iostream>
#include<string>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;
int main(){
int A, B = 0;
string result;
cin >> A >> B;
int mul = A*B;
while (mul > 0){
int a = mul % 10;
mul = mul / 10;
result += to_string(a);
}
char x = result[0];
int j = 1;
if (x == '0'){
while (j<result.length() && result[j] == x){
j++;
}
for (int i = j; i < result.length(); i++){
cout << result[i];
}
}
else{
if (result.length() >= 1){
cout << result << endl;
}
else{
cout << 0 << endl;
}
}
return 0;
}