1059 C语言竞赛 (20分)
C 语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:
0、冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
1、排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
2、其他人将得到巧克力。
给定比赛的最终排名以及一系列参赛者的 ID,你要给出这些参赛者应该获得的奖品。
输入格式:
输入第一行给出一个正整数 N(≤10^4),是参赛者人数。随后 N 行给出最终排名,每行按排名顺序给出一位参赛者的 ID(4 位数字组成)。接下来给出一个正整数 K 以及 K 个需要查询的 ID。
输出格式:
对每个要查询的 ID,在一行中输出 ID: 奖品,其中奖品或者是 Mystery Award(神秘大奖)、或者是 Minion(小黄人)、或者是 Chocolate(巧克力)。如果所查 ID 根本不在排名里,打印 Are you kidding?(耍我呢?)。如果该 ID 已经查过了(即奖品已经领过了),打印 ID: Checked(不能多吃多占)。
输入样例:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
输出样例:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?
解题思路:用map来存放id与排名的对应关系,利用set来存取已查询过的id。根据排名输出对应的奖品即可。
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<cmath>
using namespace std;
int a[10001];
map<int, int> stuMap;
set<int> stuSet;
bool isPrime(int x){
bool flag = true;
for (int i = 2; i <= (int)sqrt(x); i++){
if (x%i == 0){
return false;
}
}
return true;
}
string printOut(int x){
if (stuMap[x] == 0){
return "Are you kidding?";
}
if (stuSet.find(x) == stuSet.end()){
stuSet.insert(x);
}
else{
return "Checked";
}
if (stuMap[x] == 1){
return "Mystery Award";
}
if (isPrime(stuMap[x])){
return "Minion";
}
return "Chocolate";
}
int main(){
int N = 0,temp=0;
cin >> N;
for (int i = 0; i < N; i++){
cin >> temp;
stuMap[temp]=i+1;
}
int x = 0;
cin >> x;
for (int i = 0; i < x; i++){
cin >> temp;
string str = printOut(temp);
printf("%04d: %s\n", temp, str.c_str());
}
return 0;
}