J - 滑雪
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
25
思路:
广度优先搜索+记忆化数组,广搜用队列来实现,这次没有用递归了。
AC代码:
#include <cstdio>
#include <queue>
using namespace std;
const int maxn = 120;
int vis[maxn][maxn];
int dp[maxn][maxn];
int dx[4] = {-1, 0, 1, 0}, dy[4] = {0, 1, 0, -1};
int r, c;
struct node
{
int x, y, step;
node(int x = 0, int y = 0, int step = 0)
{
this->x = x;
this->y = y;
this->step = step;
}
};
int solove(int x, int y)
{
if (vis[x][y] != 0)
return vis[x][y];
int ans = 1;
queue<node> que;
que.push(node(x, y, 1));
node temp;
while (que.size())
{
temp = que.front(), que.pop();
int nx, ny, ns;
for (int i = 0; i < 4; i++)
{
nx = temp.x + dx[i], ny = temp.y + dy[i];
if (nx >= 1 && nx <= r && ny >= 1 && ny <= c && dp[nx][ny] < dp[temp.x][temp.y])
{
if (vis[nx][ny] != 0)
{
ns = temp.step + vis[nx][ny];
ans = max(ans, ns);
}
else
{
ns = temp.step + 1;
que.push(node(nx, ny, ns));
}
}
}
}
return vis[x][y] = max(ans, temp.step);
}
int main(void)
{
//freopen("input.txt", "r", stdin);
scanf("%d%d", &r, &c);
for (int i = 1; i <= r; i++)
for (int j = 1; j <= c; j++)
scanf("%d", &dp[i][j]);
int ans = 0;
for (int i = 1; i <= r; i++)
for (int j = 1; j <= c; j++)
ans = max(ans, solove(i, j));
printf("%d\n", ans);
return 0;
}