Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
Sample Output
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
这道题跟小希的迷宫有很大的相似吧,只是一个是无向图一个是有向图。也是给你那些结点之间的信息,然后让你判断是不是一颗树罢了,用树的定义来 判断吧,无环,n个结点最多有n-1条边。只有一个入度为0的根结点,不存在入度大于1的结点。不过要注意 一些特殊数据的情况,空树也是树。比如输入0 0。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
#define MAX 100001
const int max_num = 100000+10;
typedef struct
{
int num,root,conn;
}Node;
Node node[max_num];
void init()
{
for(int i = 0; i < max_num; i++)
{
node[i].conn = 0;
node[i].root= i;
node[i].num=0;
}
}
int find_root(int a)
{
if(node[a].root!=a)
return node[a].root = find_root(node[a].root);
return node[a].root;
}
void union_set(int a,int b)
{
a = find_root(a);
b = find_root(b);
if(a==b)
return;
node[b].root=a;
}
int main()
{
int n,m;
int i = 1;
bool flag=true;
init();
while(scanf("%d%d",&n,&m)!=EOF&&n>=0&&m>=0)
{
if(!flag&&n!=0&&n!=0)continue;
if(n==0&&m==0)
{
int root_num=0;
for(int j = 1; j < max_num;j++)
{
if(node[j].num && find_root(j)==j)
root_num++;
if(node[j].conn>1)
{
flag = false;
break;
}
}
if(root_num>1)
flag=false;
if(flag)
printf("Case %d is a tree.\n",i++);
else printf("Case %d is not a tree.\n",i++);
flag = true;
init();
continue;
}
if((m!=n&&find_root(n)==find_root(m))||m==n)
flag = false;
else
{
node[m].num = 1;
node[n].num = 1;
node[m].conn++;
union_set(n,m);
}
}
return 0;
}