找字符串的最长后缀

问题

1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
结尾无空行
Sample Output 1:
nyan~
结尾无空行
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
结尾无空行
Sample Output 2:
nai

思路

结构体存储每一个字符串,以及其长度。定义一个结构体数组,按长度从小到大对数组排序。遍历排序后数组中的第一个字符串,对比其他字符串,相同则把该字符拼接到答案上。

代码

#include <bits/stdc++.h>
#include <algorithm>
using namespace std;
struct node{
    char str[260];
    int len;
};
vector<node> sentence;
bool cmp(node a,node b){
    return a.len<b.len;
}

int main() {
    string str;
    int n;
    cin>>n;
    getchar();
    for (int i = 0; i < n; ++i) {
        node s;
        scanf("%[^\n]",&s.str);
        s.len = strlen(s.str);
        reverse((s.str),s.str+s.len);
        sentence.push_back(s);
        getchar();
    }
    sort(sentence.begin(),sentence.end(),cmp);
    string ans="";
    for (int j = 0; j < strlen(sentence[0].str); ++j) {
        for (int i = 1; i < sentence.size(); ++i) {
            if(sentence[0].str[j]!=sentence[i].str[j]){
                if(ans=="")
                    cout<<"nai"<<endl;
                else{
                    reverse(ans.begin(),ans.end());
                    cout<<ans<<endl;
                }
                return 0;
            }
            else if(sentence[0].str[j]==sentence[i].str[j] && i==sentence.size()-1){
                ans.push_back(sentence[0].str[j]);
                if(j==strlen(sentence[0].str)-1)
                    cout<<ans<<endl;
            }
        }
    }
    return 0;
}

总结

1.因为字符串中可能包含空格,所以要用scanf,以换行作为结束符。注意输入n后要用getchar吸收掉换行符。
2.对于只有一个字符的串,如果他们相等,那么他们的最长后缀就是它本身。这种情况要特判。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值