问题
1031 Hello World for U (20 分)
Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n
1
characters, then left to right along the bottom line with n
2
characters, and finally bottom-up along the vertical line with n
3
characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n
1
=n
3
=max { k | k≤n
2
for all 3≤n
2
≤N } with n
1
+n
2
+n
3
−2=N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!
结尾无空行
Sample Output:
h !
e d
l l
lowor
结尾无空行
思路
字符串总长(N+2)/3即可求得左右两个竖直方向的字符数量。然后N+2减去竖直方向的字符数量剩下的就是底部的字符数量。
代码
#include <bits/stdc++.h>
using namespace std;
const int maxn = 85;
char str[maxn];
int main(){
cin>>str;
int len = strlen(str);
int n1 = (len+2)/3,n3 = len+2 -(len+2)/3*2,i;
for (i = 0; i < n1-1; ++i) {
cout<<str[i];
for (int k = 0; k < n3 - 2; ++k) {
cout<<" ";
}
cout<<str[len-1-i];
if(i!=n1-1)
cout<<endl;
}
for (int k = i; k < n1+n3-1; ++k) {
cout<<str[k];
}
cout<<endl;
return 0;
}
总结
注意字符的输出顺序是蛇形的。