1016 Phone Bills (25分)
A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (
MM:dd:HH:mm
), and the wordon-line
oroff-line
.For each test case, all dates will be within a single month. Each
on-line
record is paired with the chronologically next record for the same customer provided it is anoff-line
record. Anyon-line
records that are not paired with anoff-line
record are ignored, as areoff-line
records not paired with anon-line
record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.Output Specification:
For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (
dd:HH:mm
), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10 10 CYLL 01:01:06:01 on-line CYLL 01:28:16:05 off-line CYJJ 01:01:07:00 off-line CYLL 01:01:08:03 off-line CYJJ 01:01:05:59 on-line aaa 01:01:01:03 on-line aaa 01:02:00:01 on-line CYLL 01:28:15:41 on-line aaa 01:05:02:24 on-line aaa 01:04:23:59 off-line
Sample Output:
1016 Phone Bills (25分)
A long-distance telephone company charges its customers by the following rules:
Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.
Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.
The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.
The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (
MM:dd:HH:mm
), and the wordon-line
oroff-line
.For each test case, all dates will be within a single month. Each
on-line
record is paired with the chronologically next record for the same customer provided it is anoff-line
record. Anyon-line
records that are not paired with anoff-line
record are ignored, as areoff-line
records not paired with anon-line
record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.Output Specification:
For each test case, you must print a phone bill for each customer.
Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (
dd:HH:mm
), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10 10 CYLL 01:01:06:01 on-line CYLL 01:28:16:05 off-line CYJJ 01:01:07:00 off-line CYLL 01:01:08:03 off-line CYJJ 01:01:05:59 on-line aaa 01:01:01:03 on-line aaa 01:02:00:01 on-line CYLL 01:28:15:41 on-line aaa 01:05:02:24 on-line aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01 01:05:59 01:07:00 61 $12.10 Total amount: $12.10 CYLL 01 01:06:01 01:08:03 122 $24.40 28:15:41 28:16:05 24 $3.85 Total amount: $28.25 aaa 01 02:00:01 04:23:59 4318 $638.80 Total amount: $638.80
这道题让我比较迷的一点,题目中明明说了: It is guaranteed that at least one call is well paired in the input,确保输入中至少有一个通话是配对正确的,但是测试案例中还是出现了 有的人一个正确的配对都没有,那么月消费就是0,这种人是不用输出的。(测试点1,2)
比如输入
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
2
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
应该什么都不输出,而不是
aaa 01
Total amount: $0.00
这个点卡了很久,是我理解错了吗?
#include <bits/stdc++.h>
using namespace std;
struct node { //储存输入
string time, stauts;
};
struct node2 { //储存输出
string begin, end;
int interval;
double cost;
};
int rate[30];
map < string, vector < node >> ma;
vector < node2 > ans;
int cmp(node a, node b) {
return a.time < b.time;
}
double calculate(node a, node b) {//计算两个时间之间多少分钟,多少话费
int m, d1, h1, m1, d2, h2, m2;
sscanf(a.time.c_str(), "%d:%d:%d:%d", & m, & d1, & h1, & m1);
sscanf(b.time.c_str(), "%d:%d:%d:%d", & m, & d2, & h2, & m2);
int cnt = 0, res = 0;
while (1) {
if (m1 == m2 && h1 == h2 && d1 == d2) {
ans.push_back({a.time.substr(3), b.time.substr(3), cnt, res * 1.0 / 100});
return res / 100.0;
}
m1++;
cnt++;
res += rate[h1];
if (m1 > 59) {
m1 = 0;
h1++;
if (h1 > 23) {
h1 = 0;
d1++;
}
}
}
}
int main() {
for (int i = 0; i < 24; i++) {
scanf("%d", & rate[i]);
}
int n;
scanf("%d", & n);
for (int i = 0; i < n; i++) {
string a, b, c;
cin >> a >> b >> c;
ma[a].push_back({b, c});
}
string a, b;
for (auto it = ma.begin(); it != ma.end(); it++) {
vector < node > v = it -> second;
sort(v.begin(), v.end(), cmp); //按照时间先后排序
double sum = 0;
for (int i = 0; i < v.size() - 1; i++) { //如果先后两条记录可以配对
if (v[i].stauts == "on-line" && v[i + 1].stauts == "off-line")
sum += calculate(v[i], v[i + 1]);
}
if (sum != 0) {
printf("%s %s\n", it -> first.c_str(), it -> second[0].time.substr(0, 2).c_str());
for (int i = 0; i < ans.size(); i++) {
printf("%s %s %d $%.2lf\n", ans[i].begin.c_str(), ans[i].end.c_str(), ans[i].interval, ans[i].cost);
}
ans.clear();
printf("Total amount: $%.2lf\n", sum);
}
}
system("pause");
}