ArcSoft, Inc. is a leading global professional computer photography and computer vision technology company.
There are NN working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into KK new blocks by the following two operations:
- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.
Now the CEO wants to know the minimum operations to re-arrange current blocks into KKblock with equal size, please help him.
InputFirst line contains an integer
TT, which indicates the number of test cases.
There are NN working blocks in ArcSoft company, which form a straight line. The CEO of ArcSoft thinks that every block should have equal number of employees, so he wants to re-arrange the current blocks into KK new blocks by the following two operations:
- merge two neighbor blocks into a new block, and the new block's size is the sum of two old blocks'.
- split one block into two new blocks, and you can assign the size of each block, but the sum should be equal to the old block.
Now the CEO wants to know the minimum operations to re-arrange current blocks into KKblock with equal size, please help him.
Every test case begins with one line which two integers NN and KK, which is the number of old blocks and new blocks.
The second line contains NN numbers a1a1, a2a2, ⋯⋯, aNaN, indicating the size of current blocks.
Limits
1≤T≤1001≤T≤100
1≤N≤1051≤N≤105
1≤K≤1051≤K≤105
1≤ai≤1051≤ai≤105OutputFor every test case, you should output 'Case #x: y', where x indicates the case number and counts from 1 and y is the minimum operations.
If the CEO can't re-arrange KK new blocks with equal size, y equals -1.Sample Input
3 1 3 14 3 1 2 3 4 3 6 1 2 3Sample Output
Case #1: -1 Case #2: 2
Case #3: 3
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
/*long long gcd(long long x,long long y)
{
if(y==0)
return x;
else
return gcd(y,x%y);
}*/
long long a[200000];
int main()
{
int T;
scanf("%d",&T);
for(int k=1;k<=T;k++)
{
long long sum=0;
int n,m;
scanf("%d%d",&n,&m);
long long ans=0;
for(int i=0;i<n;i++)
{
scanf("%lld",&a[i]);
sum=sum+a[i];
}
if(sum%m)
{
printf("Case #%d: -1\n",k);
}
else
{
long long s;
s=sum/m;
long long e=0;
long long q=0;
for(int i=0;i<n;i++)
{
if(a[i]%s==0)
{
ans=ans+a[i]/s-1;
}
else
{
if(a[i]>s)
{
ans=ans+a[i]/s;
a[i+1]=a[i+1]+a[i]%s;
ans++;
}
else
{
a[i+1]=a[i+1]+a[i];
ans++;
}
}
}
printf("Case #%d: %lld\n",k,ans);
}
}
return 0;
}