poj2940 Wine Trading in Gergovia-----想法题

本文介绍了Gergovia城市的葡萄酒交易情况,每个居民都是葡萄酒商人,需求和供应总是平衡的。每天居民决定买卖的葡萄酒数量,目标是通过最优化交易路径来最小化整体运输工作。问题简化为沿直线排列的房屋,每户有特定的葡萄酒买卖需求,将一瓶酒运到隔壁房屋会产生一单位工作量。输入包含多个测试用例,每个用例给出居民数和他们的买卖需求,输出是满足所有需求的最小工作量。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Wine Trading in Gergovia
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2770 Accepted: 1248

Description

As you may know from the comic “Asterix and the Chieftain’s Shield”, Gergovia consists of one street, and every inhabitant of the city is a wine salesman. You wonder how this economy works? Simple enough: everyone buys wine from other inhabitants of the city. Every day each inhabitant decides how much wine he wants to buy or sell. Interestingly, demand and supply is always the same, so that each inhabitant gets what he wants.

There is one problem, however: Transporting wine from one house to another results in work. Since all wines are equally good, the inhabitants of Gergovia don’t care which persons they are doing trade with, they are only interested in selling or buying a specific amount of wine. They are clever enough to figure out a way of trading so that the overall amount of work needed for transports is minimized.

In this problem you are asked to reconstruct the trading during one day in Gergovia. For simplicity we will assume that the houses are built along a straight line with equal distance between adjacent houses. Transporting one bottle of wine from one house to an adjacent house results in one unit of work.

Input

The input consists of several test cases.

Each test case starts with the number of inhabitants n (2 ≤ n ≤ 100000). The following line contains n integers ai (−1000 ≤ ai ≤ 1000). If ai ≥ 0, it means that the inhabitant living in the ith house wants to buy ai bottles of wine, otherwise if ai < 0, he wants to sell −ai bottles of wine. You may assume that the numbers ai sum up to 0.

The last test case is followed by a line containing 0.

Output

For each test case print the minimum amount of work units needed so that every inhabitant has his demand fulfilled. You may assume that this number fits into a signed 64-bit integer (in C/C++ you can use the data type “long long” or “__int64”, in JAVA the data type “long”).

Sample Input

5
5 -4 1 -3 1
6
-1000 -1000 -1000 1000 1000 1000
0

Sample Output

9
9000

Source

 
算是个简单的想法题吧,贪心就行。
一开始我写了100多行的代码,华丽的runtime error~
看了一个比较好理解的代码,贴上~ 参考http://www.cnblogs.com/rainydays/archive/2011/10/08/2202076.html
#include <iostream>
#include <cstdlib>
#include <cstring>
#include <cstdio>
using namespace std;

#define maxn 100005

int n, f[maxn];

void input()
{
    for (int i = 0; i < n; i++)
        scanf("%d", &f[i]);
}

void work()
{
    int i = 0, j = 0;
    long long ans = 0;
    while (1)
    {
        while (i < n && f[i] <= 0)
            i++;
        while (j < n && f[j] >= 0)
            j++;
        if (j >= n || i >= n)
            break;
        int x = min(f[i], -f[j]);
        f[i] -= x;
        f[j] += x;
        ans += x * abs(i - j);
    }
    printf("%lld\n", ans);
}

int main()
{
    while (scanf("%d", &n), n)
    {
        input();
        work();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值