hdu 1213 求树的个数

本文介绍了一个典型的并查集问题——如何确定最少需要多少张桌子来安排互不相识的朋友就坐。通过给出完整的代码实现,帮助读者理解并查集的基本原理及应用。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

题意:

并查集模板题。不知道为什么刚开始一直内存超出。怀疑OJ有毒。
其实就是求树的个数!父节点等于本身的点是根节点!

代码:

#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 1002;

int par[maxn];
int n,m;
void init()
{
    for(int i=0;i<=n;i++)
    {
        par[i]=i;
    }
}

int solve(int x)
{
   if(par[x]==x)
   {
       return x;
   }
   else
   {
       return par[x] = solve(par[x]);
   }
}

void unite(int x,int y)
{
    int pa = solve(x);
    int pb = solve(y);
    if(pa==pb) return;
    par[pa]=pb;
}

int main()
{
    int T;

    int x,y;
    scanf("%d",&T);

    while(T--)
    {
       scanf("%d%d",&n,&m);
       init();
       for(int i=0;i<m;i++)
       {
           scanf("%d%d",&x,&y);
           unite(x,y);
       }

       int ans=0;

       for(int i=1;i<=n;i++)
       {
            if(par[i]==i)
                ans++;
       }

       printf("%d\n",ans);

     }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值