hdu 1597 前缀和+lower_bound

Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
………
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
…………
S18 = 123456789123456789
………………
现在我们把所有的串连接起来
S = 1121231234…….123456789123456789112345678912………
那么你能告诉我在S串中的第N个数字是多少吗?

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。

Output
对于每个N,输出S中第N个对应的数字.

Sample Input

6
1
2
3
4
5
10

Sample Output

1
1
2
1
2
4

题解:

先预处理出各个S的长度,计算前缀和即可,注意题目表示枚举到长度2的31次方 2147483648 即可。之后可以使用C++ STL的lower_bound 查找大于或等于x的第一个位置,减去数组首地址即是索引,也可使用二分查找。

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long LL;
const LL maxn = 2147483648;

LL data[66000];

int main()
{
    data[0]=0;
    int K;
    int i;
    for(i=1;data[i-1]+i<maxn;i++)
    {
          data[i]+=data[i-1]+i;
    }
    int right = i;
    cin>>K;
    LL N;
    while(K--)
    {
       cin>>N;
       int p = lower_bound(data+1,data+right,N)-data;
       LL tmp = N-data[p-1];
       if(tmp>9) {
      if(tmp%9==0) cout<<9<<endl;
       else cout<<tmp%9<<endl;
       }
       else cout<<tmp<<endl;
    }




    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值