Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 70077 Accepted Submission(s): 16106
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
Author
Ignatius.L
这个题目的话 主要是注意 全部都为负数 的情况 其他的就不多说了。。
#include<iostream>
using namespace std;
int main()
{
long int T,N,a[100000],b,c,sum=-100000000,sun=0,i,j,t=1;
cin>>T;
while(T--)
{
cin>>N;
for(i=0;i<N;i++)
cin>>a[i];
cout<<"Case "<<t<<':'<<endl;
for(i=0;i<N;i++)
{
for(j=i;j<N;j++)
{
sun=sun+a[j];
if(sun>sum)
{
sum=sun;
b=i;
c=j;
}
}
sun=0;
}
cout<<sum<<' '<<b+1<<' '<<c+1<<endl;
sum=-100000000;
if(T>0)
cout<<endl;
t++;
}
return 0;
}