Digital Roots

Total Submission(s) : 36 Accepted Submission(s) : 10

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output For each integer in the input, output its digital root on a separate line of the output.

Sample Input24
39
0

Sample Output6
3
利用字符减去‘0’等于数字
代替每次取余得出最后一位的方法
代码如下
#include<stdio.h>
#include<string.h>
int sum(int n);
int main()
{
 char str[1002];
 while(gets(str)&&str[0]!=‘0’){
  int i,s=0;
  for(i=0;i<strlen(str);i++){
   s+=str[i]-‘0’;
  }
  while(s>9){
   s=sum(s);
  }
  printf("%d\n",s);
 }
}
int sum(int n)
{
 int a=0;
 while(n){
  a +=n%10;
  n/=10;
 }
 return a;
}

内容概要:本文档《gee scripts.txt》记录了利用Google Earth Engine(GEE)进行遥感影像处理与分类的脚本流程。首先,对指定区域内的Landsat 5卫星图像进行了数据筛选,排除云量超过7%的影像,并应用缩放因子调整光学波段和热波段的数值。接着,基于样本数据集训练随机森林分类器,用于区分植被、水体、建筑、土壤、拜耳作物、岩石和草地等地物类型。最后,将训练好的模型应用于处理后的Landsat 5影像,生成分类结果图层,并计算混淆矩阵以评估模型准确性,同时将分类结果导出至Google Drive。 适合人群:从事地理信息系统(GIS)、遥感科学或环境监测领域的研究人员和技术人员,特别是那些希望深入了解GEE平台及其在地物分类中的应用的人士。 使用场景及目标:①从Landsat卫星获取特定时间段内的高质量影像数据;②通过预处理步骤提高影像质量,确保后续分析的有效性;③构建并训练机器学习模型以实现地物自动分类;④评估分类模型性能,保证结果可靠性;⑤将最终成果高效存储于云端平台以便进一步研究或共享。 阅读建议:由于涉及较多专业术语和技术细节,在阅读时建议先熟悉GEE平台的基本操作以及相关遥感知识,重点关注数据处理流程和分类算法的选择依据。此外,对于代码部分,可以尝试在自己的GEE环境中运行,以便更好地理解每个步骤的具体作用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值