FatMouse' Trade

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

 

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

 

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

 

Sample Input

 

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

 

 

Sample Output

 

13.333

31.500

题目描述:题意可以简化成一个老鼠用猫粮换自己的粮食有不同的换法,换取最多即可。

解题思路:我们只需要算一下每一组数据的均值,哪组数据的利润最大优先使用就可以了。所以我们可以利用结构体,算出每组的平均值,做个排序,优先选择就可以了。

代码:

#include <iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;
struct num
{
    int a,b;
    double c;
};  
bool cmp(num x,num y)
{
    return x.c>y.c;
}
int main()
{
    int m,n;
    struct num x[1005];
    double sum;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        sum=0.0;
        if(m==-1&&n==-1)
            break;
        for(int i=0;i<m;i++)
        {
            scanf("%d %d",&x[i].a,&x[i].b);
            x[i].c=x[i].a*1.0/x[i].b;  //计算每组数据的平均值
        }
        sort(x,x+m,cmp);
        for(int i=0;i<m;i++)
        {
            if(n>x[i].b)
            {
                sum=sum+1.0*x[i].a;  //换取后还有剩余就更新它剩余的猫粮
                n=n-x[i].b;
            }
            else
            {
                sum=sum+x[i].c*n;   //无剩余直接全部换掉结束
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值