Triangle Partition

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

 

Sample Input

 

1

1

1 2

2 3

3 5

 

 

Sample Output

 

1 2 3

 

解题思路:题目的大概意思就是让你用不同的点构成三角形,且每个三角形都不相交,意思就是每两个三角形之间不能有重合以及共点的情况。我们的大致思路就是让每个点的横坐标进行排序,如果横坐标相同就按总做纵坐标大小排序,这样可以让使用的点做到不重不漏。因为最后让输出的坐标,所以我们可以利用结构体来统计每个坐标的序号。利用他们的序号来输出每个点的坐标。

 

代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

struct  shu
{
    int z;
    int x,y;
}s[30005];
bool cmp(shu a,shu b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    int i,j,n,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n*3;i++)
        {
            cin >> s[i].x >> s[i].y;
            s[i].z=i+1;
        }
        sort(s,s+3*n,cmp);
        for(i=0;i<n;i++)
        {
            printf("%d %d %d\n",s[i*3].z,s[i*3+1].z,s[i*3+2].z);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值