A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.
Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.
Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
Output
For each test case, output its divisor number, one line per case.
Sample Input
4
12
0
Sample Output
3
6
#include<stdio.h>
#include<algorithm>
using namespace std;
int main ()
{
long long n,i;
while(~scanf("%lld",&n)&&n)
{
int a=1,b=1,c=1,d=1;
while(n%2==0)
{
a++;
n/=2;
}
while(n%3==0)
{
b++;
n/=3;
}
while(n%5==0)
{
c++;
n/=5;
}
while(n%7==0)
{
d++;
n/=7;
}
printf("%d\n",a*b*c*d);
}
return 0;
}