题目链接:http://acm.tju.edu.cn/toj/showp2896.html
Time Limit: 4.0 Seconds Memory Limit: 65536K
Total Runs: 419 Accepted Runs: 177

Mary[0] > Mary[1] < Mary[2] > Mary[3] < ...
Input
The first line of input will contain a single integer T expressed in decimal with no leading zeroes. T will be at most 50. T test cases will follow.Each test case is contained on a single line. A line describing a test case is formatted as follows:
n Fred[0] Fred[1] Fred[2] ... Fred[n-1].where n and each element of Fred is an integer expressed in decimal with no leading zeroes. No line will have leading or trailing whitespace, and two adjacent integers on the same line will be separated by a single space. n will be at most 30000.
Output
For each test case, output a single integer followed by a newline --- the length of the longest subsequence Mary of Fred with the desired properties.Sample Input
4 5 1 2 3 4 5 5 5 4 3 2 1 5 5 1 4 2 3 5 2 4 1 3 5
Sample Output
1 2 5 3Tor Myklebust
Source: Waterloo Local Contest Jul. 14, 2007
贪心,
#include <stdio.h>
#define Max 30001
int a[Max],cast,n,count;
int main(){
scanf("%d",&cast);
while(cast--){
scanf("%d",&n);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
count=1;
for(int i=0;i<n-1;i++){
if(a[i]>a[i+1]){
++count;
int s=0;
for(int j=i+1;j<n-1;j++)
if((s==0&&a[j]<a[j+1])||(s==1&&a[j]>a[j+1])){
++count;
s^=1;
}
break;
}
}
printf("%d\n",count);
}
}