Language:
食物链
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 105746 Accepted: 32016
Description
动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。
Input
第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。
Output
只有一个整数,表示假话的数目。
Sample Input
100 7
1 101 1
2 1 2
2 2 3
2 3 3
1 1 3
2 3 1
1 5 5
Sample Output
3
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 5 * 100000 + 10;
int f[maxn*4];
int find(int w)
{
if(w != f[w])
{
f[w] = find(f[w]);
}
return f[w];
}
int main()
{
int n, k;
scanf("%d %d",&n, &k);
for(int i = 1; i<=n*3; i++)
{
f[i] = i;
}
int ans=0;
while(k--)
{
int d, x ,y;
scanf("%d %d %d", &d, &x, &y);
if(x < 1 || x > n || y < 1 || y > n)
{
ans++;
continue;
}
if(d == 1)
{
if(find(x) == find(y + n) || find(x) == find(y + n * 2))//x吃y,x被y吃
{
ans++;
continue;
}
if(find(x) != find(y))
{
f[find(x)] = find(y);//同类
}
if(find(x + n) != find(y + n))
{
f[find(x + n)] = find(y + n);
}
if(find(x + n * 2 ) != find(y + n * 2))
{
f[find(x + 2 * n)] = find(y + 2 * n);
}
}
if(d == 2)
{
if(find(x) == find(y) || find(x) == find(y + 2 * n))//x和y同类,x被y吃
{
ans++;
continue;
}
if(find(x) != find(y + n))//x吃y
{
f[find(x)] = find(y + n);
}
if(find(x + n) != find(y + 2 * n))
{
f[find(x + n)] = find(y + 2 *n);
}
if(find(x+ 2 * n) != find(y))
{
f[find(x + 2 * n)] = find(y);
}
}
}
printf("%d\n",ans);
return 0;
}