作业4.5

pc设置

链路聚合

lsw1
interface Eth-Trunk 1
mode lacp-static
trunkport GigabitEthernet 0/0/1 to 0/0/2
port trunk allow-pass vlan 2 3 20 30
lsw2
interface Eth-Trunk 1
mode lacp-static
trunkport GigabitEthernet 0/0/1 to 0/0/2
port trunk allow-pass vlan 2 3 20 30
trunk--lsw1
system-viewvlan batch 2 3 20 30
interface GigabitEthernet  0/0/3
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30
interface GigabitEthernet  0/0/4
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30
trunk--lsw2
system-viewvlan batch 2 3 20 30
interface GigabitEthernet  0/0/3
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30
interface GigabitEthernet  0/0/4
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30
lsw1
lacp priority 100
lsw2
lacp priority 200
interface Eth-Trunk 0
[sw1-Eth-Trunk1]max active-linknumber 2
q
[sw1]display eth-trunk  
[sw2-Eth-Trunk1]lacp preempt enable   
[sw2-Eth-Trunk1]lacp preempt delay 10

创建vlan

lsw3
system-view
vlan batch 2 3 20 30
interface GigabitEthernet  0/0/1
port link-type access
port default vlan 2 
q
interface GigabitEthernet  0/0/2
port link-type access
port default vlan 3
lw4
system-view
vlan batch 2 3 20 30
interface GigabitEthernet  0/0/1
port link-type access
port default vlan 20 
q
interface GigabitEthernet  0/0/2
port link-type access
port default vlan 30
lsw3
interface GigabitEthernet  0/0/3
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30
q
interface GigabitEthernet  0/0/4
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30
lw4
interface GigabitEthernet  0/0/3
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30
q
interface GigabitEthernet  0/0/4
port link-type trunk 
port trunk allow-pass vlan 2 3 20 30

配置mstp生成树

lsw3
stp enable
stp mode mstp
[sw3]stp region-configuration 
[sw3-mst-region]region-name aa  
[sw3-mst-region]revision-level 100  
[sw-3mst-region]instance 1 vlan 2 3 
[sw3-mst-region]instance 2 vlan 20 30
[sw3-mst-region]active region-configuration 
lsw4
stp enable
stp mode mstp
[sw4]stp region-configuration
[sw4-mst-region]region-name aa 
[sw4-mst-region]revision-level 100  
[sw-4mst-region]instance 1 vlan 2 3 
[sw4-mst-region]instance 2 vlan 20 30
[sw4-mst-region]active region-configuration   
lsw1
stp enable
stp mode mstp
[sw1]stp region-configuration 
[sw1-mst-region]region-name aa  
[sw1-mst-region]revision-level 100  
[sw-4mst-region]instance 1 vlan 2 3 
[sw1-mst-region]instance 2 vlan 20 30
[sw1-mst-region]active region-configuration   
lsw2
stp enable
stp mode mstp
[sw1]stp region-configuration 
[sw1-mst-region]region-name aa  -
[sw1-mst-region]revision-level 100  
[sw-1mst-region]instance 1 vlan 2 3 
[sw1-mst-region]instance 2 vlan 20 30
[sw1-mst-region]active region-configuration   

[sw1]stp instance 1 root primary  
[sw1]stp instance 2 root secondary 
[sw2]stp instance 2 root primary  

配置DHCP

LSW1
dhcp enable
ip policy-based-route
ip pool vlan2
network 10.0.2.0 mask 24
gateway-list 10.0.2.254
dns-list 8.8.8.8
LSW2
dhcp enable
ip policy-based-route
ip pool vlan2
network 10.0.2.0 mask 24
gateway-list 10.0.2.254
dns-list 8.8.8.8
excluded-ip-address 10.0.2.3 10.0.2.128
 

配置OSPF

lsw1
vlan 11
q
interface GigabitEthernet 0/0/5
port link-type access
port default vlan 11
q
interface Vlanif 11
ip address 10.0.11.1 30
q
lsw2
vlan 12
q
interface GigabitEthernet 0/0/5
port link-type access
port default vlan 12
q
interface Vlanif 12
ip address 10.0.12.1 30
q
AR1
Iinterface GigabitEthernet 0/0/1
ip address 10.0.11.2 30
q
int g 0/0/2
ip address 10.0.12.2 30
q
lsw1
|ospf 1
area 0
network 10.0.2.1 0.0.0.0
network 10.0.3.1 0.0.0.0
network 10.0.11.1 0.0.0.0
network 10.0.20.1 0.0.0.0
network 10.0.30.1 0.0.0.0
lsw1
|ospf 1
area 0
network 10.0.2.2 0.0.0.0
network 10.0.3.2 0.0.0.0
network 10.0.11.2 0.0.0.0
network 10.0.20.2 0.0.0.0
network 10.0.30.2 0.0.0.0
AR1
|ospf 1
area 0
network 10.0.11.2 0.0.0.0
network 10.0.12.2 0.0.0.0
network 10.0.11.1 0.0.0.0
 

配置ip

r1
interface GigabitEthernet 0/0/0
ip address 202.1.1.1 30
q
interface GigabitEthernet 0/0/1
ip address 10.0.0.1 30
q
interface GigabitEthernet 0/0/2
ip address 10.0.0.4 30
q
ip route-static 100.100.100.100 24 202.1.1.2
isp
interface GigabitEthernet 0/0/0
ip address 202.1.1.2 30
q
interface LoopBack 0
ip address 100.100.100.100 32
q
ip route-static 0.0.0.0 0 202.1.1.2
interface GigabitEthernet 0/0/0
ip address 202.1.1.1 30
q
acl 2000
rule permit source 10.0.0.0 0.0.255.255 
interface GigabitEthernet 0/0/0
nat outbound 2000

vlan聚合

lw1
sys
vlan batch 2 3 20 30
vlan 100
aggregate-vlan
access-vlan 2 3 20 30
interface GigabitEthernet  0/0/3
po li t
po t all v 2
po t all v 3
q
interface GigabitEthernet  0/0/4
po li t
po t all v 20
po t all v 30
lw2
sys
vlan batch 2 3 20 30
vlan 200
aggregate-vlan
access-vlan 2 3 20 30
interface GigabitEthernet  0/0/3
po li t
po t all v 20
po t all v 30
q
interface GigabitEthernet  0/0/4
po li t
po t all v 2
po t all v 3
lsw1
interface Vlanif 100
ip address 10.0.0.2 30
lsw2
interface Vlanif 200
ip address 10.0.0.5 30
lsw1
arp-proxy inter-sub-vlan-proxy enable 
lw2
arp-proxy inter-sub-vlan-proxy enable 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值