RTP 有效负载(载荷)类型,RTP Payload Type

别再只盯着96了!聊聊SIP通话里RTP负载类型(Payload Type)那些容易踩的坑 本文深入探讨SIP通话中RTP负载类型(Payload Type)的常见问题与解决方案,帮助开发者避免动态类型分配中的数值冲突、编码名称不匹配等陷阱。通过实战案例和抓包分析,提供终端兼容性调优策略,确保VoIP通信的稳定性和互操作性。 阅读详情

PT Encoding Name Audio/Video (A/V) Clock Rate (Hz) Channels Reference 
0PCMUA80001[RFC3551]
1Reserved    
2Reserved    
3GSMA80001[RFC3551]
4G723A80001[Vineet_Kumar][RFC3551]
5DVI4A80001[RFC3551]
6DVI4A160001[RFC3551]
7LPCA80001[RFC3551]
8PCMAA80001[RFC3551]
9G722A80001[RFC3551]
10L16A441002[RFC3551]
11L16A441001[RFC3551]
12QCELPA80001[RFC3551]
13CNA80001[RFC3389]
14MPAA90000 [RFC3551][RFC2250]
15G728A80001[RFC3551]
16DVI4A110251[Joseph_Di_Pol]
17DVI4A220501[Joseph_Di_Pol]
18G729A80001[RFC3551]
19ReservedA   
20UnassignedA   
21UnassignedA   
22UnassignedA   
23UnassignedA   
24UnassignedV   
25CelBV90000 [RFC2029]
26JPEGV90000 [RFC2435]
27UnassignedV   
28nvV90000 [RFC3551]
29UnassignedV   
30UnassignedV   
31H261V90000 [RFC4587]
32MPVV90000 [RFC2250]
33MP2TAV90000 [RFC2250]
34H263V90000 [Chunrong_Zhu]
35-71Unassigned?   
72-76Reserved for RTCP conflict avoidance   [RFC3551]
77-95Unassigned?   
96-127dynamic?  [RFC3551]

除了上表中明确指定PT值的负载类型,还有些负载类型由于诞生的较晚,没有具体的PT值,只能使用动态(dynamic)PT值,即96到127,这就是为什么大家普遍指定H264的PT值为96。下表中列出了没有具体PT值的负载类型。

Media TypeSubtype Clock Rate (Hz) Channels (audio) Reference 
application1d-interleaved-parityfec  [RFC6015]
applicationh2244800 [RFC4573]
applicationparityfec  [RFC3009]
applicationraptorfec  [RFC6682]
applicationrtx  [RFC4588]
applicationsmpte336m  [RFC6597]
applicationulpfec  [RFC5109]
audio1d-interleaved-parityfec  [RFC6015]
audio32kadpcm8000 [RFC3802][RFC2421]
audioac3  [RFC4184]
audioAMR8000 [RFC4867][RFC3267]
audioAMR-WB16000 [RFC4867][RFC3267]
audioamr-wb+72000 [RFC4352]
audioatrac344100 [RFC5584]
audioATRAC-ADVANCED-LOSSLESS  [RFC5584]
audioatrac-x  [RFC5584]
audioBV168000 [RFC4298]
audioBV3216000 [RFC4298]
audioclearmode80001[RFC4040]
audioCN  [RFC3389]
audioDAT12  [RFC3190]
audiodsr-es201108  [RFC3557]
audiodsr-es2020508000 [RFC4060]
audiodsr-es2022118000 [RFC4060]
audiodsr-es2022128000 [RFC4060]
audioDV  [RFC6469]
audioeac3  [RFC4598]
audioEVRC80001[RFC4788]
audioEVRC080001[RFC4788]
audioEVRC180001[RFC4788]
audioEVRCB80001[RFC4788]
audioEVRCB080001[RFC4788]
audioEVRCB180001[RFC4788]
audioEVRCWB  [RFC5188]
audioEVRCWB0  [RFC5188]
audioEVRCWB1  [RFC5188]
audiofwdred  [RFC6354]
audiog71948000 [RFC5404]
audioG7221160001[RFC5577]
audioG726-1680001[RFC3551][RFC4856]
audioG726-2480001[RFC3551][RFC4856]
audioG726-3280001[RFC3551][RFC4856]
audioG726-4080001[RFC3551][RFC4856]
audioG729D80001[RFC3551][RFC4856]
audioG729E80001[RFC3551][RFC4856]
audioGSM-EFR80001[RFC3551][RFC4856]
audioL8  [RFC3551][RFC4856]
audioraptorfec  [RFC6682]
audioRED  [RFC2198][RFC3555]
audiortx  [RFC4588]
audioVDVI 1[RFC3551][RFC4856]
audioL20  [RFC3190]
audioL24  [RFC3190]
audioMP4A-LATM  [RFC3016]
audiompa-robust90000 [RFC5219]
audioparityfec  [RFC5109]
audioSMV80001[RFC3558]
audioSMV080001[RFC3558]
audiot140c  [RFC4351]
audiot38  [RFC4612]
audiotelephone-event  [RFC4733]
audiotone  [RFC4733]
audioDVI4  [RFC4856]
audioG722  [RFC4856]
audioG723  [RFC4856]
audioG728  [RFC4856]
audioG729  [RFC4856]
audioGSM  [RFC4856]
audioL16  [RFC4856]
audioLPC  [RFC4856]
audioPCMA  [RFC4856]
audioPCMU  [RFC4856]
audioG729116000 [RFC4749][RFC5459]
audioGSM-HR-088000 [RFC5993]
audioiLBC8000 [RFC3952]
audioip-mr_v2.516000 [RFC6262]
audioMPA90000 [RFC3555]
audiompeg4-generic  [RFC3640][RFC5691][RFC6295]
audioPCMA-WB16000 [RFC5391]
audioPCMU-WB16000 [RFC5391]
audioQCELP  [RFC3555]
audiortp-midi  [RFC6295]
audiospeex  [RFC5574]
audiouemclip  [RFC5686]
audioulpfec  [RFC5109]
audioVMR-WB16000 [RFC4348][RFC4424]
audiovorbis  [RFC5215]
audiovorbis-config  [RFC5215]
text1d-interleaved-parityfec  [RFC6015]
textfwdred  [RFC6354]
textparityfec  [RFC3009]
textraptorfec  [RFC6682]
textred1000 [RFC4102]
textrtx  [RFC4588]
textt1401000 [RFC4103]
textulpfec  [RFC5109]
videoBMPEG90000 [RFC2343][RFC3555]
video1d-interleaved-parityfec  [RFC6015]
video3gpp-tt  [RFC4396]
videoBT65690000 [RFC2431][RFC3555]
videocelB  [RFC3555]
videoDV90000 [RFC6469]
videoH261  [RFC4587]
videoH26390000 [RFC4628]
videoH263-199890000 [RFC4629]
videoH263-200090000 [RFC4629]
videoH264  [RFC6184]
videoH264-RCDO90000 [RFC6185]
videoH264-SVC  [RFC6190]
videoJPEG  [RFC3555]
videoJPEG2000  [RFC5371]
videoMP1S90000 [RFC2250][RFC3555]
videoMP2P90000 [RFC2250][RFC3555]
videoMP2T  [RFC3555]
videoMP4V-ES90000 [RFC3016]
videompeg4-generic  [RFC3640]
videoMPV  [RFC3555]
videonv  [RFC4856]
videoparityfec  [RFC5109]
videopointer90000 [RFC2862]
videoraptorfec  [RFC6682]
videoraw90000 [RFC4175]
videortx  [RFC4588]
videoSMPTE292M  [RFC3497]
videoulpfec  [RFC5109]
videovc190000 [RFC4425]
参考链接: https://www.ietf.org/assignments/rtp-parameters/rtp-parameters.xml

RTP的H.264载荷的三种type H.264 Payload 格式定义了三种不同的基本的负载(Payload)结构. 接收端可能通过 RTP Payload的第一个字节来识别它们. 这一个字节类似 NALU 头的格式, 而这个头结构的 NAL 单元类型字段则指出了代表的是哪一种结构,这个字节的结构如下, 可以看出它和 H.264 的 NALU 头结构是一样的.       +---------------+       | 阅读详情

相关推荐

RTP PayloadType类型整理

RTP PayloadType类型整理 RTP PayloadType类型整理

RTP理解

一、TRP理解 RTP:实时传输协议(Real-time Transport Protocol或简写RTP)是一个网络传输协议. RTP定义了两种报文:RTP报文和RTCP报文,RTP报文用于传送媒体数据(如音频和视频),它由 RTP报头和数据两部分组成,RTP数据部分称为有效载荷(payload);RTCP报文用于传送控制信息,以实现协议控制功能。RTP报文和RTCP 报文将作为下层协议的数据单元进行传输。如果使用UDP,则RTP报文和RTCP报文分别使用两个相邻的UDP端口,RTP报文使用低端口,RTC

xt18971492243的博客 1万+

ZYNQ实战:如何用AXI-stream FIFO解决跨时钟域数据同步难题(附完整代码)

本文深入探讨了在ZYNQ项目中,如何利用AXI-Stream FIFO有效解决PS与PL之间的跨时钟域数据同步难题。文章详细分析了异步FIFO的架构设计、关键配置参数,并提供了PS端软件策略与PL端逻辑设计的完整代码示例,旨在帮助开发者构建稳定可靠的数据流通道,优化系统性能。

nginx7reverse的博客 754

RTP有效负载(载荷)类型,RTP Payload Type

PTEncoding NameAudio/Video (A/V)Clock Rate (Hz)ChannelsReference0PCMUA80001[RFC3551]1Reserved2Reserved3GSMA80001[RFC3551]4G723A80001[Vineet_Kumar][RFC3551]5DVI4A80001[RFC3551]6DVI4A16000...

草上爬的博客 4万+

合泰单片机HT32之keil5开发环境搭建(一)

1. 前言 这两天在准备合泰杯,但是总是感觉无从下手,因为合泰单片机的资料教程什么的非常少,不像stm32那样。而且听说要用合泰单片机的专用IDE,感觉当场被劝退了。后来经过查找资料,发现合泰单片机也有keil5的支持包,也就是说可以从库函数进行开发,不用从寄存器进行开发,但我找了好久,并没有找到教程,后来实在没办法,打算自己动手搭建环境,经过了大概两天的挣扎后,终于成功地搭建好了环境,也成功地点...

weixin_44713763的博客 8668

告别RXTX:SpringBoot集成jSerialComm实现更现代的串口通信(附完整代码对比)

本文详细介绍了如何从传统的RXTX库迁移到jSerialComm,实现SpringBoot项目中更现代的串口通信。通过对比两种技术的依赖配置、API设计和跨平台支持,展示了jSerialComm在简化部署、提升性能和增强稳定性方面的优势,并提供了完整的代码示例和实战经验。

weixin_42522964的博客 284

python工具-解析wireshark的rtp抓包

将 rtp 包数据,使用 python 解析,然后根据需要,再进一步分析

knowledgebao的博客 1620

PaddleOCR GPU部署:从环境配置到避坑实战指南

本文详细介绍了PaddleOCR GPU部署的全过程,从环境配置到避坑实战指南。通过分析常见的部署失败原因,提供硬件兼容性自查、软件环境精配方案以及路径配置的解决方案,帮助用户高效完成GPU加速的OCR任务部署,避免90%的常见错误。

weixin_30839881的博客 417

RTP有效负载(载荷)类型 (RTP Payload Type)

下图为RTP部格式: ***************************************************** 1) V:RTP协议的版本号,占2位,当前协议版本号为2 2) P:填充标志,占1位,如果P=1,则在该报文的尾部填充一个或多个额外的八位组,它们不是有效载荷的一部分。 3) X:扩展标志,占1位,如果X=1,则在RTP报头后跟有一个扩展报头 4) CC:CSRC计数器,占4位,指示CSRC 标识符的个数(作用...

小小的熊的博客 8548

科研党必备:5分钟搞定MATLAB闪退问题(含R2020a-R2023b各版本适配)

本文针对科研人员常见的MATLAB闪退问题,提供了从R2020a到R2023b各版本的适配解决方案。通过分析六大诱因和版本定制化修复方法,帮助用户快速诊断和解决闪退问题,包括内存优化、高级调试和预防性维护等实用技巧,确保科研计算的连续性和稳定性。

t1u2v的博客 1957

Canoe主要功能的详细介绍

CANoe是德国Vetor公司推出的一款用于总线开发的设备,全程为CAN open environment。后来随着总线技术的发展,CANoe不仅限于CAN类型的总线开发,还包含LIN、FlexRay、MOST和以太网等开发。在车载网络和ECU开发、测试和分析方面,CANoe几乎长期占据着垄断地位,当然是因为其强大的功能性了。目前用这个工具的主要是整车厂和供应商的网络设计工程是、开发工程师和测试工程师。小编当时安装CANoe的时候也是花了一定的时间和精力,好在没有崩溃。

车载测试 3722

基于RTP协议的H.264视频传输系统:实现

实现的原理:基于RTP协议的H.264视频传输系统:原理 相关文章: 【1】RTP协议分析 【2】jrtplib简介 【3】Qt调用jrtplib实现单播、多播和广播 【4】RTP 有效负载(载荷)类型,RTP Payload Type 【5】H.264(H264)视频文件的制作 【6】H.264格式分析 【7】H.264视频压缩标准 关于RTP Payload Format

草上爬的博客 1万+

C#的GDI+绘图详解

/消除锯齿 或 AntiAlias。// 1.在窗体或控件的Paint事件中,用PaintEventArgs e 创建绘图对象 ---- 控件或窗体重绘时。//为控件创建绘图对象。//--------------------以上方法三选一。//2.创建绘图对象 panel1中绘图。

weixin_50920631的博客 3457

RFC3984: RTP Payload Format for H.264 Video(中英文版)官方文献,RTP协议头格式分析详解;RTP载荷H264码流;

RFC3984: RTP Payload Format for H.264 Video(中英文版)官方文献,RTP协议头格式分析详解;RTP载荷H264码流;

qq_50635297的博客 895

【PCIe EP 设备入门学习专栏 -- 8 PCIe EP 架构详细介绍】

Synopsys PCIe 5.0 EP 架构由多个功能模块组成,整体遵循分层 + 模块化设计CXPL(事务层 + 链路层 + 物理层 MAC)XADM(仲裁/生成)、XAIM(应用接口)RADM(过滤/路由/Completion)CDM(配置空间)、PMC(电源管理)、LBC/DBI(寄存器访问)MSG_GEN(消息)、CXS(多芯片一致性)

CodingCos的博客 381

霍尼韦尔SoftMaster使用说明

霍尼韦尔SoftMaster使用说明

谈谈RTP传输中的负载类型和时间戳

最近被RTP的负载类型和时间戳搞郁闷了,一个问题调试了近一周,终于圆满解决,回头看看,发现其实主要原因还是自己没有真正地搞清楚RTP协议中负载类型和时间戳的含义。虽然做RTP传输,有着Jrtplib和Ortp这两个强大的库支持,一个是c++接口,一个是c语言接口,各有各的特点,各有各的应用环境,但是仅仅有库就能解决一切问题吗?可能仿照着一些例子程序,你能够完成主要的功能,但一旦问题发生了,不清楚原...

夜空中最亮的星 731

迈瑞BS系列全自动生化分析仪LIS协议接口手册(内含HL7和ASTM)

迈瑞BS系列全自动生化分析仪LIS协议接口手册,内含HL7和ASTM)

RTP负载类型定义

RTP封包中的有效负载类型(Payload Type)的栏位长度为7位元,因此RTP可以支援128种不通的有效负载类型。这个栏位用来指示声音或影像使用的编码类型,而且由发送端决定,不过当然前提是接收端也要拥有处理的能力。如果发送端在会话或者广播的中途决定改变编码方式,发送端可通过这个栏位来通知接收端。下面列出一些目前RTP所能支援的声音、影像有效负载类型。 有效负载号 (PT)      

htjx99的专栏 2088

怀旧版电脑GBC模拟器

再现原版GBC掌机的界面,电脑运行连游戏界面都一样大小,很怀旧,很真实,(英文版)强烈推荐,很小的文件,很难才找到的。

TMS_WebGMaps_1.9.8.0_Full_Source

TMS_WebGMaps_1.9.8.0_Full_Source 全源码 delphi cbuilder

上一篇: sdp文件详细总结
下一篇: rtp,rtcp网络音视频写入(avi)文件,音视频同步方案
mincheat
博客等级 码龄17年 46粉丝 43原创
评论
成就一亿技术人!
拼手气红包6.0元
还能输入1000个字符
 
 条评论被折叠 查看
添加红包

请填写红包祝福语或标题

个

红包个数最小为10个

元

红包金额最低5元

当前余额3.43元 前往充值 >
需支付:10.00元
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值