Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 73705 | Accepted: 34947 |
Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

Input
Output
Sample Input
1.00 3.71 0.04 5.19 0.00
Sample Output
3 card(s) 61 card(s) 1 card(s) 273 card(s)
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
vector<double> vf;
double c = 0;
cin >> c;
while(c) {
vf.push_back(c);
cin >> c;
}
for(vector<double>::iterator iter = vf.begin();
iter != vf.end();
++iter) {
double sum = 0.0;
int i = 1;
for(i = 1; sum < *iter; i++) {
sum += 1.0 / (i + 1);
}
cout << i - 1 << " card(s)" << endl;
}
}