noi-8176-验证子串

验证子串


总时间限制: 
1000ms 
内存限制: 
65536kB
描述

输入两个字符串,验证其中一个串是否为另一个串的子串。

输入
输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。
输出
若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2) 
否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1) 
否则,输出 No substring。
样例输入
abc
dddncabca
样例输出
abc is substring of dddncabca
来源
JerryCircle[Java 语言程序设计]

//noi_8176
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<iomanip>

using namespace std;

int main(){
	string s1,s2;
	string tem1,tem2;
	getline(cin,s1);
	getline(cin,s2);
	if(s1.length()<=s2.length()){
		tem1=s1;
		tem2=s2;
	}
	else {
		tem1=s2;
		tem2=s1;
	}
	for(int i=0;i<tem2.length();i++){
		if(tem1[0]==tem2[i]){
			for(int j=0;j<tem1.length();j++){
					if(tem1[j]==tem2[i+j]) {
						if(j==tem1.length()-1) {
							cout<<tem1<<" is substring of "<<tem2;
							return 0;
						}
					//	continue;
					}
					else break;
				}
		}
		
	}
	cout<<"No substring";
	return 0;
}



评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值