Stock Exchange(LIS优化)-动态规划加二分

文章介绍了一种解决最长上升子序列(LIS)问题的优化方法,由于常规的O(n^2)解决方案在大数据范围下会导致超时,因此采用O(nlogn)的时间复杂度算法。代码示例展示了如何使用动态规划和二分查找来实现这一优化,以找到股票价格序列中的最长上升趋势。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

一定要手拟几个样例,演算一下,不然想不明白二分的过成;

Stock Exchange
题目描述:

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,…,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < … < pik, with i1 < i2 < … < ik. John’s problem is to find very quickly the longest rising trend.

Input
Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer).
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output
The program prints the length of the longest rising trend.
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input
6
5 2 1 4 5 3
3
1 1 1
4
4 3 2 1

Sample Output
3
1
1

求最长上升子序列(LIS),由于数据范围比较大,普通的求最长上升子序列的方法时间复杂度为o(n^2),这里明显会超时,所以需要用时间复杂度为o(nlogn)的方法来优化。

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int MAX=120022,M=11111;
long long dp[1001][1001];
long long ans[MAX];
long long a[MAX];
int main()
{
	int n;
	while(cin>>n&&n)
	{
		memset(a,0,sizeof(a));
		memset(ans,0,sizeof(ans));
		for(int i=0;i<n;i++)
		{
			cin>>a[i];
		}
		int num=1;
		ans[1]=a[0];
		for(int i=1;i<n;i++)
		{
			if(a[i]>ans[num])
			{
				ans[++num]=a[i];
			}
			else
			{
				int l=0,r=num,mid;
				while(l<=r)
				{
					mid=(l+r)/2;
					if(ans[mid]<a[i])
					l=mid+1;
					else{
						r=mid-1;
					}
				}
				ans[l]=a[i];
			}
		}
		cout<<num<<endl;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值