- 利用接口做参数,写个计算器,能完成加减乘除运算。
- 定义一个接口ICompute含有一个方法int computer(int n, int m)。
- 定义Add类实现接口ICompute,实现computer方法,求m,n之和
- 定义Sub类实现接口ICompute,实现computer方法,求n-m之差
- 定义Main类,在里面输入两个整数a, b,利用Add类和Sub类的computer方法,求第一个数a和第二个数b之和,输出和,第一个数a和第二个数b之差,输出差。
输入格式:
输入在一行中给出2个整数
输出格式:
输出两个数的和、差
输入样例:
在这里给出一组输入。例如:
6 7
输出样例:
在这里给出相应的输出。例如:
13
-1
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
答案
import java.util.Scanner;
interface ICompute
{
public int computer(int n,int m);
}
class Add implements ICompute
{ int n,m;
Add(int n,int m)
{
this.n=n;
this.m=m;
}
public int computer(int n,int m)
{
return n+m;
}
}
class Sum implements ICompute
{
int n,m;
Sum(int n,int m)
{
this.n=n;
this.m=m;
}
public int computer(int n,int m)
{
return n-m;
}
}
public class Main
{
public static void main(String[] args)
{
Scanner sc =new Scanner(System.in);
int a,b;
a=sc.nextInt();
b=sc.nextInt();
ICompute s=new Add(a,b);
ICompute n=new Sum(a,b);
System.out.println(s.computer(a,b));
System.out.println(n.computer(a,b));
}
}