7-1 接口--四则计算器

  • 利用接口做参数,写个计算器,能完成加减乘除运算。
  1. 定义一个接口ICompute含有一个方法int computer(int n, int m)。
  2. 定义Add类实现接口ICompute,实现computer方法,求m,n之和
  3. 定义Sub类实现接口ICompute,实现computer方法,求n-m之差
  4. 定义Main类,在里面输入两个整数a, b,利用Add类和Sub类的computer方法,求第一个数a和第二个数b之和,输出和,第一个数a和第二个数b之差,输出差。

输入格式:

输入在一行中给出2个整数

输出格式:

输出两个数的和、差

输入样例:

在这里给出一组输入。例如:

6 7

输出样例:

在这里给出相应的输出。例如:

13
-1

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

答案



import java.util.Scanner;
interface ICompute
{   
    public int computer(int n,int m);
}
class Add implements ICompute
{  int n,m;
    Add(int n,int m)
    {
        this.n=n;
        this.m=m;
    }
    public int computer(int n,int m)
    {
        return n+m;
    }
}
class Sum implements ICompute
{
    int n,m;
    Sum(int n,int m)
    {
        this.n=n;
        this.m=m;
    }
    public int computer(int n,int m)
    {
        return n-m;
    }
}
public class Main
{
    public static void main(String[] args)
    {
        Scanner sc =new Scanner(System.in);
        int a,b;
        a=sc.nextInt();
        b=sc.nextInt();
        ICompute s=new Add(a,b);
        ICompute n=new Sum(a,b);
       
        System.out.println(s.computer(a,b));
        System.out.println(n.computer(a,b));

    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小白宇航(互关版)

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值