本题要求你写个程序把给定的符号打印成沙漏的形状。例如给定17个“*”,要求按下列格式打印
*****
***
*
***
*****
所谓“沙漏形状”,是指每行输出奇数个符号;各行符号中心对齐;相邻两行符号数差2;符号数先从大到小顺序递减到1,再从小到大顺序递增;首尾符号数相等。
给定任意N个符号,不一定能正好组成一个沙漏。要求打印出的沙漏能用掉尽可能多的符号。
输入格式:
输入在一行给出1个正整数N(≤1000)和一个符号,中间以空格分隔。
输出格式:
首先打印出由给定符号组成的最大的沙漏形状,最后在一行中输出剩下没用掉的符号数。
输入样例:
19 *
输出样例:
*****
***
*
***
*****
2
[代码]
#include <iostream>
using namespace std;
class solution {
public:
solution(int i, char c) :num(i),key(c) {}
void print() {
if (num == 0) {
cout << endl << 0 << endl;
return;
}
int i = 1, cnt = 0, extra;
for (; cnt < num; i += 2)
if (i != 1) cnt += i * 2;
else cnt++;
if (cnt != num)
cnt -= (i -= 2) * 2;
i -= 2;
extra = num - cnt;
printsand(i, i);
cout << extra << endl;
}
void printsand(int i, int a) {
if (i == 1) {
for (int j = a / 2 - i / 2; j > 0; j--)
cout << ' ';
cout << key << endl;
return;
}
for (int j = a / 2 - i / 2; j > 0; j--)
cout << ' ';
for (int j = i; j > 0; j--)
cout << key;
cout << endl;
printsand(i - 2, a);
for (int j = a / 2 - i / 2; j > 0; j--)
cout << ' ';
for (int j = i; j > 0; j--)
cout << key;
cout << endl;
}
private:
int num;
char key;
};
int main() {
int i;
cin >> i;
char c;
cin >> c;
solution sandglass(i, c);
sandglass.print();
return 0;
}
打印沙漏用了递归,这当然不是最好的解法,但是我脑子有限。。。