Let the Balloon Rise

博客给出一个算法问题,即统计比赛中各颜色气球数量,找出最受欢迎问题对应的气球颜色。输入包含多组测试用例,每组先给出气球总数,接着是各气球颜色,以总数为 0 结束输入,需输出每组中最受欢迎问题对应的气球颜色。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目描述
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
输入
nput contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
输出
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
样例输入
5
green
red
blue
red
red
3
pink
orange
pink
0

样例输出
red
pink

#include<iostream>
#include<string.h>
using namespace std;

typedef struct
{
	char color[15];
	int n;
}Balloon,*Case;

int Search_Balloon(Case &B,int N)
{
	int i,j,k;
	int max,flag;
	char t[N];
	for(i=1;i<N-1;i++)
	{
		strcpy(t,B[i].color);
		for(k=i;k<N-1;k++)
		{
			flag=1;
			for(j=0;j<15&&flag;j++)
			{
				if(t[j]!=B[k+1].color[j])
				{
					flag=0;
				}
				B[i].n=B[i].n+1;
			}
		}
	}
	i=2;
	max=1;
	while(i<N)
	{
		if(B[max].n<B[i].n)
		{
			max=i;
		}
		i++;
	}
	return max;
}

int main(void)
{
	Case B;
	int i,N=1,max;
	while(N!=0)
	{
		cin>>N;
		B=new Balloon[N+1];
		for(i=0;i<N+1;i++)
		{
			gets(B[i].color);
			B[i].n=0;
		}
		max=Search_Balloon(B,N);
		cout<<B[max].color<<endl;
		delete B;
	}
}

在这里插入图片描述

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值