HDOJ 1008 Elevator 超详细

本文解析了HDOJ1008电梯问题的算法实现,电梯在不同楼层间的移动时间取决于上行或下行方向,同时考虑了在每一楼层停留的时间。通过示例输入输出展示了算法的具体应用。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

HDOJ 1008 Elevator

Problem Description

The highest building in our city has only one elevator.
 A request list is made up with N positive numbers.
  The numbers denote at which floors the elevator will stop, in specified order. 
  It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor.
  The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list.
 The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers.
 All the numbers in the input are less than 100.
  A test case with N = 0 denotes the end of input. 
  This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

题意大致翻译就是,我们城市最高的建筑物只有一部电梯。 请求列表由N个正数组成。 数字按指定顺序指示电梯将停在的楼层。 将电梯上移一层需要6秒钟,而将一层下移则需要4秒钟。 电梯将在每个站点停留5秒钟。 对于给定的请求列表,您将计算完成列表上的请求所花费的总时间。 电梯在开始时位于0楼,并且在满足请求后不必返回一楼。按照所说条件写上代码就好了。

#include<stdio.h>

int main(void)
{
    int n, floor, old = 0, time = 0;
    
    while (scanf("%d", &n) && n != 0)
    {    
        time += 5 * n;//事先加好各楼层停留时间
        while (n--)
        {        
            scanf("%d", &floor);
            //old 记录当前电梯位置楼层
            if (floor > old)//上楼
            {
                time += (floor - old) * 6;
                old = floor;
            }    
            else if (floor < old)//下楼
            {
                time += (old - floor) * 4;
                old = floor;
            }            
        }    
        printf("%d\n", time);
        time = 0;//每组测试数据测试前都重置一下
        old = 0;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值