图2 Saving James Bond - Easy Version

该问题描述了一个基于电影场景的编程挑战,要求编写程序判断詹姆斯·邦德能否在被鳄鱼包围的湖中通过跳跃逃到岸边。输入包含鳄鱼的位置和邦德的最大跳跃距离,输出是能否逃脱的判断。提供的示例表明,程序应使用深度优先搜索策略来解决此问题。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

问题

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

解答

#include <iostream>

using std::pair;

class Solution
{
private:
    pair<int, int> *Crocodiles;
    bool *Status;
    int Number;
    double Diameter;
public:
    Solution(int n, int d) : Number(n), Diameter(d)
    {
        Crocodiles = new pair<int, int>[n];
        Status = new bool[n];
        for (int i = 0; i < n; ++i)
        {
            std::cin >> Crocodiles[i].first >> Crocodiles[i].second;
            Status[i] = false;
        }
    }

    bool isSafe(int i)
    {
        return ((50 - Crocodiles[i].first <= Diameter) or \
        (50 + Crocodiles[i].first <= Diameter) or \
        (50 - Crocodiles[i].second <= Diameter) or \
        (50 + Crocodiles[i].second <= Diameter));
    }

    static bool validJump(const pair<int, int> &a, const pair<int, int> &b, double diameter)
    {
        return (((a.first - b.first) * (a.first - b.first) + \
                (a.second - b.second) * (a.second - b.second)) <= \
                (diameter * diameter));
    }

    bool DFS(int u)
    {
        Status[u] = true;
        if (isSafe(u))
            return true;
        for (int v = 0; v < Number; ++v)
        {
            if (!Status[v] and validJump(Crocodiles[u], Crocodiles[v], Diameter))
            {
                if (DFS(v))
                    return true;
            }
        }
        return false;
    }

    bool save()
    {
        for (int i = 0; i < Number; ++i)
        {
            if (!Status[i] and validJump(std::make_pair(0, 0), \
            Crocodiles[i], 7.5 + Diameter))
            {
                if (DFS(i))
                    return true;
            }
        }
        return false;
    }
};

int main()
{
    int N, D;
    std::cin >> N >> D;
    Solution S(N, D);
    if (S.save())
        std::cout << "Yes\n";
    else
        std::cout << "No\n";
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值