1060 Are They Equal (25 分)
If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10
5
with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.
Input Specification:
Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10
100
, and that its total digit number is less than 100.
Output Specification:
For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.
Note: Simple chopping is assumed without rounding.
Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.12310^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.12010^3 0.128*10^3
#include<string>
#include<iostream>
using namespace std;
string trans(string s,int &ans,int n){
string t;
int i=0;
while(s[0]=='0'&&s.size()>0)
{
s.erase(s.begin());
}
if(s[0]=='.')
{
s.erase(s.begin());
while(s[0]=='0'&&s.size()>0)
{
s.erase(s.begin());
ans--;
}
}
else
{
while(s[i]!='.'&&i<s.size())
{
ans++;
i++;
}
if(i<s.size())
s.erase(s.begin()+i);
}
if(s.size()==0)
ans=0;
int j=0;
i=0;
while(j<n)
{
if(i<s.size())
t+=s[i++];
else
t+='0';
j++;
}
return t;
}
int main()
{
int n;
int ans1=0,ans2=0;
string s1,s2,s3,s4;
cin>>n>>s1>>s2;
s3=trans(s1,ans1,n);
s4=trans(s2,ans2,n);
if(s3==s4&&ans1==ans2)
cout<<"YES 0."<<s3<<"*10^"<<ans1;
else
{
cout<<"NO 0."<<s3<<"*10^"<<ans1<<" 0."<<s4<<"*10^"<<ans2;
}
return 0;
}
//数据部分(前导0) 指数部分(小数点)