C++实现 HDU 1062 Text Reverse

博客围绕反转文本中单词顺序的编程问题展开,给出输入输出要求,包含多个测试用例,每行最多1000字符,还给出示例输入输出,同时提示使用getchar()和gets()处理输入,最后提及两种解决方法。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

Hint
Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.

Method1

#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
using namespace std; 
int main() {
	int T;
	cin >> T; 
	getchar();
	while(T--) {
		int start = 0, end = 0;
		string s;
		getline(cin, s);
		if(s[0] == ' ' && s[1] != ' '){
			start = 1;
			end = 1;
			cout << ' ';
		}
		for(int i = start; i < s.length(); i++) {
			if(s[i + 1] == ' ' || i == s.length() - 1){
				for(int j = i; j >= end; j--) cout << s[j];
				if(s[i + 1] == ' ') cout << ' ';
				end = i + 2;
			}
		}
		cout << endl;
	}
	return 0;
}

Method2(stack)

#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<stack> 
using namespace std; 
int main() {
	int T;
	cin >> T;
	getchar();
	while(T--) {
		stack<char> s;
		while(true) {
			char ch = getchar();
			if(ch == ' ' || ch == '\n' || ch == EOF) {
				while(!s.empty()) {
					cout << s.top();
					s.pop();
				}
				if(ch == '\n' || ch == EOF) break;
				cout << " ";
			} 
			else s.push(ch);
		}
		cout << endl;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值