1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

Sample Solution:

#include <iostream>
using namespace std;

//使用数组下标作为指数,数组对应值为系数
int main() {
	int k1,k2,temp,k=0;
	double x1[1001]={0.0},x2[1001]={0.0},res[2001]={0.0};
	cin>>k1;
	for(int i=0;i<k1;i++){
		cin>>temp>>x1[temp];
	}
	cin>>k2;
	for(int i=0;i<k2;i++){
		cin>>temp;
		cin>>x2[temp];
	}
	for(int i=0;i<1001;i++){
		for(int j=0;j<1001;j++){
			res[i+j]+=x1[i]*x2[j];
		}
	}
	for(int i=0;i<2001;i++){
		if(res[i]!=0)k++;
	}
	cout<<k;
	for(int i=2000;i>=0;i--){
		if(res[i]!=0)printf(" %d %.1f",i,res[i]);
	}
}

Submit results attached

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值