Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 293669 Accepted Submission(s): 69719
Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
代码及思路:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<stdlib.h>
using namespace std;
#define MAXN 100005
//定义区间范围
#define inf -1000
// //定义最小的整数
int a[MAXN];//数组
int dp[MAXN];dp序列,表示最后一个数位为i的序列最大和
int main()
{
int i,t;
int j,sum,n;
int max0;
int end,start;//记录起点和终点的位置
cin>>t;
for(i=1;i<=t;i++)
{
cin>>n;//输入样例组数
max0=inf;//给最大值预付最小值
memset(a,0,sizeof(a));//清零
memset(dp,0,sizeof(dp));//清零
end=0;
start=0;
for(j=1;j<=n;j++)
{
cin>>a[j];//输入数组
dp[j]=max(dp[j-1]+a[j],a[j]);如果这个新加去的数比dp[j-1]+a[j](序列和)要大,
//则放弃序列和,以该数为起点,重新开始
//反之,把该数加进序列和
if(max0<dp[j]){
max0=dp[j];//找到序列和最大的数的终点的位置
end=j;//记录终点和序列和的值
}
}
sum=0;
for(j=end;j>=1;j--)
{
sum=sum+a[j];
if(sum==max0){
start=j;
break;
}
}//找起点
cout<<"Case "<<i<<":"<<endl;
printf("%d %d %d\n",max0,start,end);
if(i!=t)
cout<<endl;//输出控制
}
return 0;
}
补充关于dp方程的验证
注意这里的第二个样例是错的