题目:
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24
39
0
Sample Output
6
3
思路:
是一个水题,只有一个要注意的地方。
- 因为输入的位数可能非常长,所以C++里规定的所有整型都可能不够长。
- 因此采用一个String对象来储存最原始的输入。
- 由于一个几万位的数字各位的数字加起来其和业不过即使几十万
- 因此后面的结果可以直接用int型储存。
- 注意本题看上去是一个数字问题,其实,主要考察的是字符串的内容
附上代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int sumDig(string n)
{
int sum,i;
sum=0;
for(i=0;i<n.size();i++){//n.size()求string的长度
sum=sum+n[i]-48;
}
return sum;
}//第一次计算各位和用
int sumDig2(int n)
{
int sum=0;
while(n!=0){
sum=sum+n%10;
n=n/10;
}
return sum;
}//除第一次外计算各位和用
int main()
{
string n;
int sum;
while(cin>>n&&!(n=="0")){
sum=sumDig(n);
while(sum>=10){
sum=sumDig2(sum);
}
cout<<sum<<endl;
}
return 0;
}