Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 30403 | Accepted: 14206 |
题目链接:点击打开链接
Description

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.
Input
Output
Sample Input
9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
Sample Output
216 30
题意:
就是给你一些村庄的数目 n ,然后接着给你 n-1 组数据,每组数据的开头都是一个大写的英文字母,代表村庄的名字,然后接着后面跟着一个数字,这个数字是说,与本村庄直接相连的其他的村庄的个数,然后最后一个村庄肯定会由别的村庄连接,所以不给出它的数据,举例说:A 2 B 12 I 25,就是说与 A 村庄直接相连的村庄有两个,分别是 B 和 I ,然后 A 和 B 的距离是 12,A 与 I 的距离是 25 ,让你求出一条将所给的村庄全部连接起来的路径,两个村庄之间可以不是直接相连,可以通过别的村庄相连。
分析:
最近准备复习一下最小生成树,然后遇见的第一题就是这个题,一看英文这么多,可真是吓着我了,然后在前天拉的最小生成树的专题里,又遇见了这个题,就是昨天夜晚,准备今天写,今天确实写了,但却不是在专题里写的,而是今天夜晚的小比赛中,它竟然又存在,第一想法就是,解决它就一举三得,哈哈哈哈。。。本题真是。。。。看半天看不懂题意,当然也没看懂测试数据,然后看了一眼题,据我的经验,像这种给出图的题,第一组测试数据都会和它的图有关,目的是让读者更好的理解题意,果然,瞬间秒懂
本题读懂题就知道是道最小生成树的题,就怕读不懂题。。。因为这里的村庄的编号不是数字而是字母,所以我们可以为了节省开数组的空间,我们可以让下标全部减去‘A’,这样就可以少开点数组,其他的就没啥了。。。
#include <iostream>
#include<stdio.h>
#include<math.h>
#include<string>
#include<string.h>
#include<math.h>
using namespace std;
#define INF 0x3f3f3f3f
int s[30][30];
int n;
void prim()
{
int vis[30],low[30],bj,minx;
int sum=0;
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)
{
low[i]=s[0][i];
}
vis[0]=1;
for(int i=1;i<n;i++)
{
minx=INF;
for(int j=0;j<n;j++)
{
if(!vis[j]&&minx>low[j])
{
bj=j;
minx=low[j];
}
}
vis[bj]=1;
sum+=low[bj];
for(int j=0;j<n;j++)
{
if(!vis[j]&&low[j]>s[bj][j])
low[j]=s[bj][j];
}
}
printf("%d\n",sum);
}
int main()
{
char c1,c2;
int a,b;
while(~scanf("%d",&n)&&n)
{
for(int i=0;i<30;i++)///初始化存图的数组
{
for(int j=0;j<30;j++)
{
if(i==j)
s[i][j]=0;
else
s[i][j]=INF;
}
}
for(int i=1;i<n;i++)///存路径
{
cin>>c1>>a;
for(int j=1;j<=a;j++)
{
cin>>c2>>b;
s[c1-'A'][c2-'A']=s[c2-'A'][c1-'A']=min(s[c1-'A'][c2-'A'],b);
}
}
prim();
}
return 0;
}