1124. Raffle for Weibo Followers (20)

本文介绍了一个简单的抽奖程序设计案例,该程序用于从微博转发中选取幸运粉丝作为赢家,并考虑了同一用户多次转发的情况,确保每位用户只能获奖一次。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1124. Raffle for Weibo Followers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going...

#include<stdio.h>
#include<iostream>
#include<string>
#include<map>
using namespace std;
map<string,int>cou;
int main(){
	int m,n,s,i,flag=0;
	scanf("%d %d %d",&m,&n,&s);
	string name[1010];
	for(i=1;i<=m;i++){
		cin>>name[i];
	}
	for(i=s;i<=m;i=i+n){
		if(cou[name[i]]==0){
			cou[name[i]]=1;
			cout<<name[i]<<endl;
			flag=1;
		}
		else{
			i=i-n+1;
		}
	}
	if(flag==0){
		printf("Keep going...");
	}
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值