//trie字典树//poj1056//IMMEDIATE DECODABILITY

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable

解题思路:
跟上一道题有很多相似之处,同样是和前缀有关。因为上一道题的前缀可以是任意字符串,所以每个节点都需要一个count来记数;但是这道题的前缀必须是输入的字符串,所以只需要在每个节点加一个bool变量标记是否是字符串结尾。
因为这道题有多组数据,所以每一组数据结束后需要把之前的树全部销毁,再建立新的树。在delete函数里面,先找到树的最末端的子节点,再依次往回用free函数释放内存空间。
insert函数的结构比较简单,但是要注意一直更新根节点,我忘了在节点存在的情况下也要更新根节点,就一直过不了。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>

struct trie
{
    bool end;
    trie *next[2];
};

bool flag;

void init(trie *m)
{
    for(int i=0;i<2;i++)
        m->next[i]=NULL;
    m->end=false;
    flag=false;
}

void dele(trie *m)
{
    for(int i=0;i<2;i++)
        if(m->next[i]!=NULL)
            dele(m->next[i]);//到树的最末端
    free(m);//释放内存空间
}

void insert(char *str,trie *m)
{
    int len=strlen(str);
    int num;
    trie *head=m;
    for(int i=0;i<len;i++)
    {
        num=str[i]-'0';
        if(head->next[num]==NULL)//节点还没有建立
        {
            head->next[num]=new trie;
            head=head->next[num];
            for(int j=0;j<2;j++)
                head->next[j]=NULL;
            head->end=false;
        }
        else//节点已经存在
        {
            if(head->next[num]->end==true)//此节点是其他字符串的结尾
            {
                flag=true;
                return;
            }
            else//此节点不是其他字符串结尾
                head=head->next[num];//根节点更新为当前字符
        }
    }
    head->end=true;//最后一个字符的节点标记为字符串末尾
}

int main()
{
    char code[20];
    int set=0;
    trie *root=new trie;
    init(root);
    while(scanf("%s",code)!=EOF)
    {
        if(code[0]=='9')
        {
            set++;
            if(flag==false)
                printf("Set %d is immediately decodable\n",set);
            else
                printf("Set %d is not immediately decodable\n",set);
            dele(root);
            root=new trie;
            init(root);
        }
        else
        {
            if(flag==false)//还未找到相同前缀
                insert(code,root);
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值