PTA: jmu-ds-最长数字序列

输入一个字符串,求该字符串中最长连续数字序列出现的起始位置及其长度。

输入格式:

输入一个字符串,可包含空格。

输出格式:

输出内容:最长数字序列起始位置和长度空格隔开。输出尾部不能有空格。输入空串,输出"NULL"

输入样例:

123ab12345a

输出样例:

5 5

一开始的代码:

#include<iostream>
#include<string>
using namespace std;

int main()
{
    string a;
    getline(cin,a);
    if(a.empty())
    {
        cout<<"NULL";
        return 0;
    }
    int maxLength=0;
    int startIndex=0;
    int currentLength=0;
    int currentStart=0;
    for(int i=0;i<a.length();i++)
    {
        if(isdigit(a[i]))
        {
            if(currentLength==0)
            {
                currentStart=i;
            }
            currentLength++;
        }else{
            if(currentLength>maxLength)
            {
                maxLength=currentLength;
                startIndex=currentStart;
            }
            currentLength=0;
        }
    }
    cout<<startIndex<<" "<<maxLength;
    return 0;
}

没有考虑到最后一个字符是数字的情况,应该添加一个 if 语句来确保只有一个字符是数字且该字符在最末位时的情况。

最终代码如下:

#include<iostream>
#include<string>
using namespace std;

int main()
{
    string a;
    getline(cin,a);
    if(a.empty())
    {
        cout<<"NULL";
        return 0;
    }
    int maxLength=0;
    int startIndex=0;
    int currentLength=0;
    int currentStart=0;
    for(int i=0;i<a.length();i++)
    {
        if(isdigit(a[i]))
        {
            if(currentLength==0)
            {
                currentStart=i;
            }
            currentLength++;
        }else{
            if(currentLength>maxLength)
            {
                maxLength=currentLength;
                startIndex=currentStart;
            }
            currentLength=0;
        }
    }
    if(currentLength>maxLength)
    {
        maxLength=currentLength;
        startIndex=currentStart;
    }
    cout<<startIndex<<" "<<maxLength;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值