POJ 2418 Hardwood Species(二叉搜索树\二叉排序树)

该博客介绍了如何利用二叉搜索树(二叉排序树)解决POJ 2418题目,即统计不同硬木种类在森林中所占的比例。通过读取卫星数据,对每个物种进行计数,然后按字母顺序输出物种名称及其所占百分比。提示中建议使用scanf避免因输入数据量大导致的时间超限。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Hardwood Species
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 22529 Accepted: 8792
Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter.
America’s temperate climates produce forests with hundreds of hardwood species – trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States.

On the other hand, softwoods, or conifers, from the Latin word meaning “cone-bearing,” have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications.

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.
Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.
Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.
Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow
Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483
Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.
Source

Waterloo Local 2002.01.26

本题主要是在字符串输入花了比较长时间,由于对string不熟悉,故最终还是选择使用字符数组表示字符串。
解题思路:建立二叉搜索树,然后在进行中序遍历即可得结果(关于二叉搜索树的算法可以在数据结构书中找到)
收获:复习了cin.getline()的用法,该函数可以有两个或三个参数,第一个为字符串指针,第二个为读入字符串个数减1,第三个为标志位。测试结果如下:

测试程序
测试第二个参数
测试第三个参数

本题代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int total=0;//记录树木的总数
typedef struct Tree
{
    struct Tree *lchild;
    struct Tree *rchild;
    int count;
    char name[35];
    Tree(struct Tree *m_lchild,struct Tree *m_rchild,int m_count,char m_name[])//构造函数,可以在new的同时赋值
    {
        lchild=m_lchild;
        rchild=m_lchild;
        count=m_count;
        strcpy(name,m_name);
    }
}*BSTree,BSTNode;
void insertBST(BSTree *root,char s[])//二叉搜索树的插入
{
    if((*root)==NULL)
        (*root)=new BSTNode(NULL,NULL,1,s);
    else if(strcmp(s,(*root)->name)==0)
        (*root)->count++;
    else if(strcmp(s,(*root)->name)<0)
        insertBST(&((*root)->lchild),s);
    else
        insertBST(&((*root)->rchild),s);

}
void inOrderBST(BSTree root)//中序遍历
{
    if(root!=NULL)
    {
        inOrderBST(root->lchild);
        printf("%s %.4f\n",root->name,((root->count)/(double)total)*100);
        inOrderBST(root->rchild);
    }
}
int main()
{
    BSTree root=NULL;
    char s[35];
    //cinscanf遇到空格会停止读入,“Red Alder“该字符串无法读入,故使用getline()读入一行字符串
    while(cin.getline(s,35))
    {
        total++;
        insertBST(&root,s);

    }
    inOrderBST(root);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值