A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
暴力做肯定超时,所以用深搜做。每次判断是否满足素数,如果满足继续搜下去,直到有n个数,同时把前40个数是否是素数保存起来可省不少时间
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
int a[21],n,b[21];//a数组用来存数,b数组用来判断数有没有用过
bool isprime(int t){
for(int i=2; i*i <= t; ++i){
if(t%i==0)return false;
}
return true;
}
bool ans[41];
void dfs(int k){
if(k > n) return ;
if(k==n){
for(int i=0; i < n-1; ++i) cout << a[i] << " ";
cout << a[n-1] << endl;
return ;
}
for(int i=2; i <= n; ++i){
if(b[i]==1) continue;
if(k+1==n){
if(ans[i+a[k-1]]&&ans[i+1]){
a[k]=i;
b[i]=1;
dfs(k+1);
b[i]=0;
}
}
else{
if(ans[i+a[k-1]]){
a[k]=i;
b[i]=1;
dfs(k+1);
b[i]=0;
}
}
}
}
int main()
{
int k=1;
for(int i=0; i < 41; ++i) ans[i]=isprime(i);
while(cin >> n){
cout << "Case " << k << ":" << endl;
k++;
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
a[0]=b[0]=1;
dfs(1);
cout << endl;
}
}