uva 111 History Grading(DP初步应用)

                  uva 111 History Grading


Many problems in Computer Science involve maximizing some measure according to constraints.

Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?

Some possibilities for partial credit include:

  1. 1 point for each event whose rank matches its correct rank
  2. 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.

For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).

In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events tex2html_wrap_inline34 as tex2html_wrap_inline36 where tex2html_wrap_inline38 denotes the ranking of event i in the correct chronological order and a sequence of student responses tex2html_wrap_inline42 where tex2html_wrap_inline44 denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with tex2html_wrap_inline50 . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range tex2html_wrap_inline60 , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9



题目大意:第一个数n 代表数据中元素的个数, 然后是一个标准答案, 接下来是其他同学的答案, 求出两个序列的最长公共子序列, 注意给出的答案均是以该事件处于第几个发生的, 例如 :2 3 4 1

即是 对应第1个事件在第2个发生,第2个事件在第3个发生 ...转换一下就是  4 1 2 3。


解题思路:

d[i][j] = 

0( i == 0 ||  j == 0)

d[i - 1] [j - 1] + 1 ( a[i] == b[i])

max(d[i - 1][j] , d[i] [j - 1])



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[25], b[25], dp[25][25];
int main() {
	int n, t;
	while (scanf("%d", &n) == 1) {
		for (int i = 1; i <= n; i++) {
			scanf("%d", &t);
			a[t] = i;
		}
		while (scanf("%d", &t) == 1) {
			b[t] = 1;
			for (int i = 2; i <= n; i++) {
				scanf("%d", &t);
				b[t] = i;
			}
			memset(dp, 0, sizeof(dp));
			for (int i = 1; i <= n; i++) {
				for (int j = 1; j <= n; j++) {
					if (a[i] != b[j]) {
						dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
					}
					else {
						dp[i][j] = dp[i - 1] [j - 1] + 1;
					}
				}
			}
			printf("%d\n", dp[n][n]);
		}
	}
	return 0;
}


在Unity中,动态设置PostProcessingBehaviour的ColorGrading可以通过以下步骤实现: 1. **确保导入PostProcessing包**:首先,确保你的项目中已经导入了PostProcessing包。如果没有,可以通过Unity的Package Manager进行导入。 2. **添加PostProcessingBehaviour组件**:在你的相机上添加PostProcessingBehaviour组件。如果没有,可以通过`AddComponent<PostProcessingBehaviour>()`方法动态添加。 3. **创建PostProcessingProfile**:创建一个PostProcessingProfile资产,并配置好ColorGrading设置。 4. **动态修改ColorGrading设置**:通过代码动态修改PostProcessingProfile中的ColorGrading设置。 以下是一个示例代码,展示了如何动态设置ColorGrading: ```csharp using UnityEngine; using UnityEngine.Rendering.PostProcessing; public class DynamicColorGrading : MonoBehaviour { public PostProcessProfile postProcessProfile; void Start() { // 获取ColorGrading设置 ColorGrading colorGrading; if (postProcessProfile.TryGetSettings(out colorGrading)) { // 设置ColorGrading的参数 colorGrading.temperature.value = 2000f; // 设置色温 colorGrading.tint.value = 50f; // 设置色调 colorGrading.postExposure.value = 0.5f; // 设置曝光 colorGrading.contrast.value = 1.5f; // 设置对比度 } } } ``` 在这个示例中,我们首先确保导入了`UnityEngine.Rendering.PostProcessing`命名空间。然后,我们通过`TryGetSettings`方法获取ColorGrading设置,并动态修改其参数。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值