课程练习二-1003-pie

探讨如何在有限数量和大小不一的圆形披萨中,为特定人数等分出相同体积的披萨片,采用二分查找算法确定最大可能的份额。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. <br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>
 

Input
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.<br>
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
  
  
3<br>3 3<br>4 3 3<br>1 24<br>5<br>10 5<br>1 4 2 3 4 5 6 5 4 2<br>
 

Sample Output
  
  
25.1327<br>3.1416<br>50.2655<br>
 
题意:
有f+1个人分n块披萨,每个人要求分得的面积一样,且披萨只能被切开而不能重新组合,求每个人能分到的最大面积v。
注意:F个朋友+自己
思路:
每个人要得到一张完整的饼,而不能多个组合。对最大的饼(high)与0(low)进行二分,判断mid是否sum(size[i])/mid是否大于等于F+1;

AC代码:

#include<iostream>
#include<iomanip>
#include<stdlib.h>
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;


bool judge(double mid,int n,int f,double size[])
{
int  p = 0;
for (int i = 0; i < n; ++i)
{
p += int(size[i] / mid);
}
return p >= f+1;
}


int main()
{
int n;
cin >> n;
while (n--)
{
int N, F;
double pi = acos(-1);
cin >> N >> F;
double size[10001];
memset(size, 0, sizeof(size));
int a = 0;
for (int i = 0; i < N; i++)
{
cin >> a;
size[i] = a*a*pi;  //把每个饼的面积存入数组,本来是将半径存入数组最后进行pi*r*r的,结果总是通不过测试数据。
}
double high = size[0];
for (int i = 0; i < N; i++)
{
if (size[i]>high)
{
high = size[i];
}
}
double mid;
double low = 0;
double ans = 0;
//cout << high << endl;
while ((high - low) > 0.00001)
{
mid = (high + low) / 2;
//cout << judge(mid, N, F, size) << endl;
if (judge(mid, N, F, size))
{
low = mid;
ans = mid;
}
else {
high = mid;
}
}
//cout << ans << endl;
double jg = ans;
cout << setprecision(4) << fixed <<jg<< endl;
}
system("pause");
return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值