https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1246
题目:
John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing two integers,1 <= n <= 100andm.nis the number of tasks (numbered from1ton) andmis the number of direct precedence relations between tasks. After this, there will bemlines with two integersiandj, representing the fact that taskimust be executed before taskj. An instance withn = m = 0will finish the input.
Output
For each instance, print a line withnintegers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3
import java.util.Arrays;
import java.util.Scanner;
public class Main {
static int[][] G;//图
static int[] c;//判断每个节点的访问状态
static int[] topo;//记录拓扑排序的结果
static int m,n,t;
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
while(true){
n = scan.nextInt();
m = scan.nextInt();
if((m+n)==0)
break;
G = new int[n+1][n+1];
c = new int[n+1];
topo = new int[n+1];
for(int i=1;i<=n;i++){
for(int j=1;j<=n;j++){
G[i][j] = 0;
}
}
Arrays.fill(c, 0);
for(int i=0;i<m;i++){
int a = scan.nextInt();
int b = scan.nextInt();
G[a][b] = 1;
}
if(topsort()){
String str = "";
for(int i=1;i<=n;i++){
str+=topo[i]+" ";
}
System.out.println(str.trim());
}else{
System.out.println("No");
}
}
}
//dfs
public static boolean dfs(int u){
c[u] = -1;
for(int v = 1;v<=n;v++) if(G[u][v]==1){
if(c[v]==-1)
return false;
else if(c[v]==0&&!dfs(v))
return false;
}
c[u] = 1;
topo[--t] = u;
// System.out.println(u);
return true;
}
public static boolean topsort(){
t = n+1;
for(int u=1;u<=n;u++){
if(c[u]==0&&!dfs(u)){
return false;
}
}
return true;
}
}