uva 10305 Ordering Tasks(拓扑排序)

本文介绍了一个关于任务调度的问题,具体为约翰需要完成一系列相互依赖的任务,并探讨了如何通过图论中的拓扑排序来找到可能的任务执行顺序。文章提供了一段Java代码实现,包括构建任务依赖图、使用深度优先搜索进行拓扑排序等关键步骤。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1246


题目:


John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.


Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers,1 <= n <= 100andm.nis the number of tasks (numbered from1ton) andmis the number of direct precedence relations between tasks. After this, there will bemlines with two integersiandj, representing the fact that taskimust be executed before taskj. An instance withn = m = 0will finish the input.


Output

For each instance, print a line withnintegers representing the tasks in a possible order of execution.


Sample Input

5 4
1 2
2 3
1 3
1 5
0 0

Sample Output

1 4 2 5 3


题目大意:

约翰有n个任务要做, 不幸的是,这些任务并不是独立的,执行某个任务之前要先执行完其他相关联的任务。
\

import java.util.Arrays;
import java.util.Scanner;
public class Main {
	static int[][] G;//图
	static int[] c;//判断每个节点的访问状态
	static int[] topo;//记录拓扑排序的结果
	static int m,n,t;
	public static void main(String[] args) {
		Scanner scan = new Scanner(System.in);
		while(true){
			n = scan.nextInt();
			m = scan.nextInt();
			if((m+n)==0)
				break;
			
			G = new int[n+1][n+1];
			c = new int[n+1];
			topo = new int[n+1];
			for(int i=1;i<=n;i++){
				for(int j=1;j<=n;j++){
					G[i][j] = 0;
				}
			}
			Arrays.fill(c, 0);
			for(int i=0;i<m;i++){
				int a = scan.nextInt();
				int b = scan.nextInt();
				G[a][b] = 1;
			}
			
			if(topsort()){
				String str = "";
				for(int i=1;i<=n;i++){
					str+=topo[i]+" ";
				}
				System.out.println(str.trim());
			}else{
				System.out.println("No");
			}
			
			
		}
	}
	//dfs
	public static boolean dfs(int u){
		c[u] = -1;
		for(int v = 1;v<=n;v++) if(G[u][v]==1){
			if(c[v]==-1)
				return false;
			else if(c[v]==0&&!dfs(v))
				return false;
		}
		c[u] = 1;
		topo[--t] = u;
//		System.out.println(u);
		return true;
	}
	public static boolean topsort(){
		t = n+1;
		for(int u=1;u<=n;u++){
			if(c[u]==0&&!dfs(u)){
				return false;
			}
		}
		return true;
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值