Little Q and Little T are playing a game on a tree. There are nn vertices on the tree, labeled by 1,2,...,n1,2,...,n, connected by n−1n−1 bidirectional edges. The ii-th vertex has the value of wiwi.
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between xx and yy, he can't grab both xx and yy. After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.
Input
The first line of the input contains an integer T(1≤T≤20)T(1≤T≤20), denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000)n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are nn integers w1,w2,...,wn(1≤wi≤109)w1,w2,...,wn(1≤wi≤109), denoting the value of each vertex.
For the next n−1n−1 lines, each line contains two integers uu and vv, denoting a bidirectional edge between vertex uu and vv.
Output
For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.
Sample Input
1 3 2 2 2 1 2 1 3
Sample Output
Q
题目大意: Q 与 T 玩游戏, 在一个无向图中,有n个点和n-1条边 ,每个顶点都有对应的价值w, Q先从n个顶点中任意选取不相邻的顶点,即任意两个顶点间都没有直接相连的边 ,剩余的顶点都为T所有 ,各自将对应顶点的价值异或和 ,谁大谁胜出 ,平局输出D
思路: 先将所有点的价值异或 ,如果为0 , 则无论Q怎么拿 剩下的异或和一定与其相等。否则Q直接选取大的一部分
#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm>
#include <queue>
using namespace std;
int main()
{
int n, t;
scanf("%d", &t);
int i, j ;
while( t-- )
{
int x, y;
scanf("%d", &n);
scanf("%d", &x);
for(int i = 0; i<n-1; i++)
{
scanf("%d", &y);
x = x^y;
}
int a, b;
for(int i = 0; i<n-1; i++)
{
scanf("%d%d", &a, &b);
}
if( x == 0 )
{
printf("D\n");
}
else
printf("Q\n");
}
return 0;
}