手工计算除法的思路:凑整数,够除即除,不够除商0。
在下手写代码之前,首先想清楚需要用什么存储数据,以及存储什么类型的数据。
- 存储所要除的大数:因为大数可能会超过int或者long long的范围,所以不能用其来进行存储,需要用string来存储。
- 除数:用int来进行存储即可。
- 计算得到的结果:将计算所得的每一位数据保存到整型数组中,int result[100001]。
- 每一次计算所得到的余数,用int来存储。
- 在result[]中存储的下标。
例题跟踪
Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.
Input
Input starts with an integer T (≤ 525), denoting the number of test cases.
Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.
Output
For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.
Sample Input
6
101 101
0 67
-101 101
7678123668327637674887634 101
11010000000000000000 256
-202202202202000202202202 -101
Sample Output
Case 1: divisible
Case 2: divisible
Case 3: divisible
Case 4: not divisible
Case 5: divisible
Case 6: divisible
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include <queue>
#include <iostream>
using namespace std;
#define maxn 100000005
char s1[300];
char s3[300];
int main()
{
int t;
scanf("%d", &t);
int cn = 1;
while( t-- )
{
memset( s1, 0, sizeof( s1 ));
memset( s3, 0, sizeof( s3 ));
long long int chu;
scanf("%s%lld", s1, &chu);
int i = 0;
int j = 0;
if( s1[0] == '-')
i++;
long long int ans = 0;
int cnt = 0;
for( i ; i<strlen( s1 ); i++)
{
ans = ans*10 + (s1[i]-'0');
if( cnt > 0 || ans >= chu )
{
s3[cnt++] = ans/chu;
ans = ans%chu;
}
}
if( ans == 0 )
{
printf("Case %d: divisible\n", cn++);
}
else
printf("Case %d: not divisible\n", cn++);
}
}